1 Reply Latest reply: Feb 12, 2018 7:29 AM by Grant Perkins RSS

    Div/0 error in summary

    LeeAnn Gill

      Hello!

       

      We have a measure in a summary where the formula for one record is 0/0 which is leaving the field blank.  We then export this file to upload into another program and it's creating an error because we can't have a blank field.  We tried to fill nulls with 0.0000 but it still doesn't export with that.

       

      Is there a way to do something similar to the iferror formula in Excel so that we can get a number in that field.

       

      Thanks!

       

      LeeAnn

        • Re: Div/0 error in summary
          Grant Perkins

          LeeAnn,

           

          Which format are you using to export to the other application?

           

          Is the other application flexible enough to accept more than one format? You have more control in text formats for example and you can multiple process to include them.

           

          That said for a single value it might be more practical to simple edit the value after export depending on the frequency of use, etc., etc.

           

          Does the target application's data ingestion process have any settings that would allow blanks to be interpreted as zero? (I assume not bit there may be functionality that has not previously been revealed to you.)

           

          Is your 0/0 calculation the result of part of the measure formula in the Summary? (I read you description and assumed it is.)

           

           

          HTH.

           

          Grant

           

          For reference here is a very old forum post for a suggested approach but it is based on fixing the challenge in the Table not the summary. Ignore the apparent posting date  - it's an import from a much older forum. And, sadly, the links will no longer work even if you manage to figure out what they are supposed to be.

           

          Exporting Null values as Zero