4 Replies Latest reply: Mar 22, 2017 5:11 AM by a2z143 _ RSS

    Report View Wrap

    a2z143 _

      Datawatch,

       

      Is there a way to prevent the report from wrapping in the report view?

       

       

       

      Thanks...

       

      Dan Alaniz

      Client Integration Services

      VALIC

      2919 Allen Parkway, L10-10

      Houston, TX 77019

       

      Tel +1 713 831 5138

      daniel.alaniz@valic.com<mailto:daniel.alaniz@valic.com>

      VALIC.com

       

       

        • Re: Report View Wrap
          Chris Porthouse

          What version of Monarch are you using?  What is the data type you are viewing (Text, PDF, CSV, etc.)?  I just tried opening a report with line lengths of 300 and it does not wrap at all.  I don't even see the option to turn wrapping on/off.  I tested with Monarch v13.5 and a text file with carriage return/line feeds in it.

          • Re: Report View Wrap
            Steve Caiels

            Hi Daniel,

             

            Monarch won't normally introduce any line wrapping.  It should truncate at (I think) 1024 characters in V12.  It's 4000 in V14.  How does it look if you open it in notepad with line wrapping turned off?

             

            If it looks OK in notepad, but not in Monarch, then there may be some embedded control codes in there.  I don't recall these ever causing line wraps, but I guess they could.

            I don't have V12 to hand, but you should find an option to Ignore unused print or control codes in the input->text files section of options.

             

            Or you could try changing the encoding between ANSI, ASCII and UTF-8.  You'll also find these settings under Options->Input->Text Files..  This should be safe for upper and lower case a to z, the numbers and most punctuation; but keep an eye on currency symbols or any accented characters that you might find in Spanish for example as they will probably change between the various encodings.

             

            If you can't control the wrapping and it is consistent, other options might be be to extract both lines of data using a multi line field under the advanced field options or to extract it as two fields then join them together as a calculation in the table.

             

            Regards,

            Steve.