6 Replies Latest reply: May 31, 2016 11:53 AM by rtrem RSS

    How do you use a workspace file in automator

    rtrem

      Hello All,

      I have an Excel spreadsheet with a date in cell A1, rates in cells A4 to A100 and a 3 character code in cells B4 through B100.

      A1 = Date
      A4 - A100 = Rates
      B4 - B100 = 3 Character codes.

      I need to have a date associated with each rate. Using DataPrep Studio to do the following:
      Added a calculated column to the table with the row number - RowNo(). Created a table listing just the date and added a calculated column to that table with RowNo(). Joined the two tables on row number and now have a date associated with all the rows in the table.

       

      I saved the workspace in DataPrep and opened it Monarch in classic mode. Using Classic I removed blank rows, the row number columns, and did some minor formatting. I added a filter to show only rows with a 3 character code. I saved the model and project.

       

      I uploaded the WorkSpace, Project and model files to the Automator server. I created a Standard Process that uses the original spreadsheet as the data source. The export is to a SQL database, but I also tried a CSV file for fun. When I run the process it returns an error of; "No value given for one or more required parameters." There are no parameters in the model. I assume it’s because the model was built on the WorkSpace, not the spreadsheet.
      Is it possible to get the model to use the output of the Workspace? If not, what good is using workspace files on the Automator?
      I welcome any comments or suggestions.
      Thank you.