4 Replies Latest reply: Sep 21, 2015 11:10 AM by Jean-Charles Peyrondet RSS

    Name of month not in alphabetic order

    Jean-Charles Peyrondet

      Hy,

       

      In a summary, I want to see the data of the year, sort by the month of the year.

      I can see the data now for the year 2015, and I choice of key the name of month field

      But the name of months appears in alphabetic order.

      How can change that to have :

      January | February | March | ...

       

      Thks

       

      Sorry for my English :-/

        • Re: Name of month not in alphabetic order
          Theo Klemming

          Hi Jean-Charles

           

          I assume that you are working in Datawatch Designer?

          Provided that you have a column with real dates, like for example 2015-01-31, you should right-click that column and select "Time Bucketing Columns". That will take you to the settings for what time-based text categories, such as year and month, that you would like to derive from the dates. Since these are pulled form the dates, Datawatch will know how to sort them in time order instead of alphabetic order.

           

          best regards, Theo Klemming

            • Re: Name of month not in alphabetic order
              Jean-Charles Peyrondet

              Hy Theo,

              Thanks for your speed consideration !

               

              No, I m in Datawatch Monarch v13

              Yes I have a (Main) date column in Date/Time type and Long Date Format, with it, I create a Month Column and a Year Column.

              All Data comes from a DataBase.

              I search in TableDesign, but i can't get up...

                • Re: Name of month not in alphabetic order
                  Olly Bond

                  Hello Jean-Charles,

                   

                  There are two ways to do this in Monarch. In the Summary window, you can set the Month key field in the Matching tab to "Match specified values" and enter the months in the specified values list in the correct order, then in the Sorting tab set the field to sort on the "Specified values list". This is boring, especially if you have to repeat the listing of the names of the months in lots of key definitions for lots of summaries.

                   

                  This was the only way until v11 (I think) which introduced Time Intervals. Now you can set the key and tell Monarch that it is a Time Interval, so it should sort correctly. The problem is that if you have made a field called Month with the content like "janvier" and this field is a character field, then Monarch can't guess that this means the first month of a calendar year. So you should use the (Main) date column as the key and select the options to break it at the level of detail (year, quarter, month, week, day) as needed.

                   

                  Hope this helps,

                   

                  Olly