1 Reply Latest reply: Mar 25, 2015 12:24 PM by Olly Bond RSS

    Remove pesky number lines column when copying and pasting to Excel

    Alex Fliegel

      Hi all,

       

      So I have a feeling the answer to this question is relatively simple to answer, but I for some reason cannot resolve it myself.

       

      I am working on using Datawatch to automate a few processes, however when I attempt to copy and paste the data into excel, along with my data datawatch also pastes number lines in column "A" of excel which really throws off any automation. Is there any way to turn off this feature of automatically pasting these number lines in Excel, or will I have to use the traditional Export method?

       

      Thank you!

       

       

       

       

      HeaderHeaderHeaderHeaderHeaderHeaderHeaderHeaderHeaderHeaderHeader
      1DataDataDataDataDataDataDataDataDataDataData
      2DataDataDataDataDataDataDataDataDataDataData
      3DataDataDataDataDataDataDataDataDataDataData
      4DataDataDataDataDataDataDataDataDataDataData
      5DataDataDataDataDataDataDataDataDataDataData
      6DataDataDataDataDataDataDataDataDataDataData
      7DataDataDataDataDataDataDataDataDataDataData
      8DataDataDataDataDataDataDataDataDataDataData
      9DataDataDataDataDataDataDataDataDataDataData
      10DataDataDataDataDataDataDataDataDataDataData
      11DataDataDataDataDataDataDataDataDataDataData
      12DataDataDataDataDataDataDataDataDataDataData
      13DataDataDataDataDataDataDataDataDataDataData
      14DataDataDataDataDataDataDataDataDataDataData
      15DataDataDataDataDataDataDataDataDataDataData
      16DataDataDataDataDataDataDataDataDataDataData
      17DataDataDataDataDataDataDataDataDataDataData
      18DataDataDataDataDataDataDataDataDataDataData
      19DataDataDataDataDataDataDataDataDataDataData
      20DataDataDataDataDataDataDataDataDataDataData
      21DataDataDataDataDataDataDataDataDataDataData
      22DataDataDataDataDataDataDataDataDataDataData
        • Re: Remove pesky number lines column when copying and pasting to Excel
          Olly Bond

          Hello Alex,

           

          I love the idea of automating by manually copying and pasting to Excel - at least it means these computers won't put us all out of work just yet. Rest assured, when you export properly from Monarch or Automator to Excel they are no extra line numbers included. To add them, you'd have to define a calculated field with Rowno() to achieve that effect.

           

          In Modeler, if you click on the Home tab and select Options, you'll see a section for Clipboard, which should have what you're looking for.

           

          Best wishes,

           

          Olly