6 Replies Latest reply: May 15, 2014 10:16 AM by Walter K. RSS

    No Data in Data View

    Walter K.

      All my traps appear fine in my Report view, when I go to Data View, there is no data at all.  Anyone know why this happens??

       

      I have Monarch Pro v11.8.10.0

       

      Thanks

      Walter

        • No Data in Data View
          Olly Bond

          Hello Walter,

           

          Is at least one of your traps a Detail template? As long as there is at least one row in the report which is trapped by the Detail template, then there should be at least one row of data in the unfiltered table.

           

          In the table view, do you have a filter applied? A filter excludes rows from the table. The only other explanation might be that you've hidden all the columns in the table by setting the fields to Hidden.

           

          Best wishes,

           

          Olly

            • No Data in Data View
              Walter K.

              Thanks for your reply Olly.

               

              Yes, I have 3 templates in the model, 1 detail, 2 append.

              Like I said, I can see all my traps highlighted fine on the report but switching to Data View, no data. 

              My fields are not hidden, I have no filters.

               

              However, I get the following message when I open the model:

              "The PDF or Exps file specifies an unsupported library version. Conversions will be performed using the current library version."  The file I'm using is a PDF file.

               

              I believe I have received this message in the past with other reports and models and it converted OK.

               

              Also, I use another model with the same PDF file/report and it works OK. I see a message that it is converting but it comes out OK.

               

              Any other ideas?

               

              Thanks

                • No Data in Data View
                  Olly Bond

                  Hello Walter,

                   

                  In the PDF Input Options, you can vary the import engine that's used. Have you tried this?

                   

                  If you'd like me to test whether the PDF works OK in v12.0.2, feel free to email it over.

                   

                  Best wishes,

                   

                  Olly

                    • No Data in Data View
                      Walter K.

                      Olly,

                      You know I was thinking about the import engine.

                      However, I was used to seeing it in v 10.5, there is a drop down to change it.

                      But in the version I have, v11.8.10.0, I don't know where to find it.

                      It is not on the PDF Input Options page.  There is Monospace, Freeform etc, etc. but no Engine?

                       

                      Maybe you can enlighten me!

                       

                      Thanks again!

                        • No Data in Data View
                          Olly Bond

                          Hi Walter,

                           

                          v12.0.2 has "Use legacy PDF engine" as an option under Advanced in the Options menu, but you're right, that seems to be missing in 11.8.

                           

                          It's no longer in the PDF Input Options menu in either edition.

                           

                          I can check whether the v12.0.2 option helps solve the problem if you can send me the file.

                           

                          Also, Datawatch Support are always keen to get sample "bad" PDFs to help improve the parsing engine for future builds, so it might be worth reaching out to them.

                           

                          Best wishes,

                           

                          Olly

                            • No Data in Data View
                              Walter K.

                              Thanks a lot for your help Olly.

                              I had to leave for the day yesterday, so, I only had a chance to respond now.

                              I'll contact  Datawatch to let them know I don't have a PDF engine option in my version and maybe they can add it to an update or something.

                               

                              Thanks again.