15 Replies Latest reply: May 15, 2014 10:16 AM by Carol _ RSS

    Monarch Pro v 10.0 opens but will not run a SAVED Model and will not export to EXCEL

    Carol _

      Problem:  Can not run Monarch Pro v10 models on standalone Windows 8 installation - full security rights - i am

       

      only user of this computer.

       

      System:  Dell T3600, 8 processors/16 cores 64GB RAM, 64-bit

       

      Single User

       

      1.  Initial issue of this computer was a Dell-installed Windows 7

      2.  I installed and used Monarch Pro v10 from a full version of Monarch Pro v9.0 with an upgrade to Monarch Pro v

       

      10.

      3.  I upgraded to Windows 8 - all parts of Monarch v 10 worked flawlessly

      -


      4.  This month I contracted a virus and had to format my hard drive.  With the help of Dell I did a clean install

          of Windows 8 and started installing my programs.

      5.  I tried to install Monarch Pro by starting with full version of 9.0 and the installation stalled at the message

          that it was Completing Setup at 95%.  I waited 10 minutes, closed the dialog box and went on with the Monarch  

       

         Pro v10 upgrade - same behavior - stalled at 95%.  I left it for 3 hours then closed the dialog box.

      6.  Monarch program opened, opened a file - but all attempts of invoking a model resulted in "Monarch application  

       

          file has stopped working" -     "Close Program"

      7.  Then I opened Monarch, opened a file, CREATED A NEW MODEL, RAN IT WITHOUT SAVING IT, data populated the table  

       

         but I was unable to export it to Excel, only to a text file.

      8.  Then I saved the "new" model and attempted to invoke it, only to fail with the same message.

       

      -


      9.  Directed my Windows 8 machine to open Monarch on a Vista 64bit - program opened on the Windows 8 machine.

      10. Modified the model to use the Monarch program on Vista 64 bit - Monarch opened

      11. Modified the model to use both the Monarch program and the Monarch model on the Vista machine - failed with    

       

          same error.

       

      -


      12 Tried to UNINSTALL MONARCH from Windows 8 machine - from Control Panel

         a.  Control Panel asks for Monarch disks - I put it in drive - I have no choices - it runs through all processes

       

      AS IF it is re-installing and hangs at 95% same as if I were installing it.  I left it overnight - it never

       

      compeleted.

       

      I also ran program with Administrator rights and also tried compatibility modes to no success.

       

      The paths of my new installation are exactly the same as the old installation.  I have reformatted and reinitiated

       

      the command lines in my modesl icons.  That being said, the behaviour when I open Monarch manually and try to

       

      invoke a newly made model results in the same error message; Monarch will not run a model manually invoked of

       

      inovked from my icon on the Windows 8 installation.

       

      The only error message when I am IN MONARCH invoking the model manually is above.  When I click on my formerly

       

      working Monarch model icons - nothing happens, no Monarch opening, no error message.  When I look in Task Manager,

       

      Monarch is not resident either.

       

       

      Is there any help for me?

       

      I have Googled with no success, I have read the Datawatch forums with no success.

       

      thank you for any help.

        • Monarch Pro v 10.0 opens but will not run a SAVED Model and will not export to EXCEL
          Olly Bond

          Hello Carol,

           

          Have you tried a clean install of the v11.7 demo? The only version of Monarch that is supported officially on Windows 7 and 8 is v11 - the others were released too early.

           

          The problem is that when you run Monarch you're calling a whole load of components - Windows Presentation Framework, JET or the Access Database Engine, Excel drivers,  etc - that any slightly out of synch Office or Windows or Monarch could lead to problems. Monarch is pretty good at coping with older Office formats and Windows versions, but (perhaps understandably) less good at dealing with things that were invented after it was released.

           

          I must say I'm green with envy at the spec of machine you have there - that sounds like a $5000 machine. Do you need to process enormous reports?

           

          Best wishes,

           

          Olly

            • Monarch Pro v 10.0 opens but will not run a SAVED Model and will not export to EXCEL
              Scott Eshleman

              Hi Carol,

               

              You likely got around the compatibility issues previously due to having Monarch 10 installed on Windows 7 before upgrading to Windows 8. 

              Do you absolutely have to upgrade[/I] to Windows 8?  If so, I can think of a few possible options for you:

               

              Olly's suggestion to demo the Monarch ver.11.7 trial.

              Use virtualization software like VMware Workstation on your nicely-powered PC to maintain a Windows 7 installation on which to run Monarch 10.

              Reinstall Windows 7 and Monarch 10 before installing Windows 8.

              /LIST

              I was lucky enough to have had a very nicely-powered PC at my last assignment.

              I was also lucky enough to NEED /BVMware Workstation installed in order to run another critical software pkg. 

              It became a very optimal solution as 'snapshots' (point-in-time backups) of the installation could be done regularly. 

              If you came down with another virus, you could revert to an earlier snapshot in no time at all. 

               

               

               

              Scott