6 Replies Latest reply: May 15, 2014 10:15 AM by Julie Reeder RSS

    Disspearing Summary Results

    ARICE01 _

      I am a longtime Monarch Professional user, and try to stay on top of the new releases, with high expectation of increased productivity.  I am currently running Monarch Pro V11.6, 64-bit.  My experience in 64-bit has been less than stellar, and I regret making the leap... Should have stayed in the 32-bit world.  Oh well!!!

       

      My latest problem (and frustration) with Monarch Pro V11.6 is disappearing Summaries.  Almost always, when I Edit a Summary and click "OK" to run, the summary results either disappears completely, or I have to Click "Refresh" to get the full results to re-publish to my screen.  Sometimes, the Summary will comeback with just the last, right-most column.  Having to refresh a Summary can be very time-consuming when running queries against large SQL server data tables, which I do a lot.

       

      I feel stuck now that I have made such an investment in my 64-bit environment (PC 64-bit configuration, all Microsoft Office software, additional memory).  I have always been impressed with Monarch, and have used it for many many years.  But the marriage is very strained at the moment.

       

      Any help or guidance on how to have better experience with Summaries would be greatly appreciated.  I will post another Summary issue (Monarch crashes when running certain Summary queries) under a new post.

       

      Thanks in advance.

        • Disspearing Summary Results
          Grant Perkins

          Hi,

           

          This is probably a long shot given your comment about using SQL server data tables (I assume extracted 'live'?) but have you got a sample file and model that you know exhibits the problem AND that you could share?

           

          I have 11.6 running on a 64bit Win 7 system (are you using Win 7?) and would be happy to do a comparative test if you have something shareable and can document what sort of tings you do that cause the problem(s).

           

          There's a lot of behind the scenes complexity out there these days and eliminating or confirming that a problem is readily reproducable can be important to making progress to a resolution.

           

          Meanwhile if anyone can tell me why my fairly new system has what appears to be a long known "COM Surrogate" problem when trying to browse a folder af basic jpg files I would love to know the solution. Search the worldwide user experience knowledge base (i.e. Google) seems to suggest there are about a thousand different fixes all of which, apparently, work. It seems a pity that something with such a long history and involving a fairly simple task can end up suddenly failing randomly for no obvious reason.

           

          11.6 has a shorter history so I guess we need to trailblaze a diagnosis if possible.

           

           

          Grant

            • Disspearing Summary Results
              Julie Reeder

              I am having the same issue with summaries appearing blank, and edits to summaries created in the previous version causing blanks as well.  I have entered a case with Datawatch, but so far, haven't received a resolution to the problem.  Most everything I work with in Monarch uses summaries, so the fact that they're not working is becoming frustrating.  I was wondering if you had figured anything out or if you were still having the same issue?

                • Disspearing Summary Results
                  Olly Bond

                  Hello everyone,

                   

                  When these timing issues crop up, the biggest unknown unknown is the network connection to the database. If you build a model that fetches the table from the database, delivers just the fields you need, and writes it to a local Access table, then you at least eliminate that factor. Then your subsequent models will be working with local data and any performance issues will be only affected by CPU and HDD speeds.

                   

                  Best wishes,

                   

                  Olly

                    • Disspearing Summary Results
                      ARICE01 _

                      Generally, I query SQL Server databases and related tables, since I have need to get at live data all the time.  If I have to run a query and then store to data on my pc (or other drive) before I can get the results I demand, then this seems very inefficient.  I never had such problem with pre-Version 11 Monarch software.

                       

                      Julie Reeder:  What version of Monarch are you using?  I thought this might be unique to Monarch V11.6 (64-Bit).  If you are using a different version, please let me know.  Thanks for your reply.

                        • Disspearing Summary Results
                          Julie Reeder

                          I am using V11.6 (32 bit).  I was initially told by the support person that I'm working with that they thought it was a bug, however, that was during our second web-ex because the files from the first web-ex were corrupt, so I'm not sure if they were really able to tell for sure from my original files or if she was just attempting a guess at the problem. 

                           

                          In my case, my report is downloaded to my network drive from Meditech--I'm not querying anything live to get my information, although it would be great to do that in the future.  I'm simply trying to change a summary because we've had a change in our structure here, and I can't do anything with them at all.

                           

                          I'll let you know if I hear back from support with a resolution.

                           

                          Julie

                            • Disspearing Summary Results
                              Julie Reeder

                              I heard back from support...they suggested adding a function to trim the space in front of the field that I was using to build my summaries.  I tried it & it worked.  My summaries now function just like they should.  Not sure why you have to do this in V11.6 when it didn't cause a problem in previous versions, but wanted to give you a heads up in hopes that it would help you with your problem too.  Thanks!