2 Replies Latest reply: May 15, 2014 10:14 AM by rsullivan _ RSS

    Question for someone new to Monarch

    rsullivan _

      I have taken over the Monarch processing and I am really new to this. I have model that has been written that parses out a semi colon delimited file as below and it works fine:

       

      10;$;ODP;3344L0;32;     0;SH;1;       768.99

      10;$;ODP;51782E;32;     0;SH;1;       435.83

       

      Recently the second field in the file was modified to have a 2 digit field as below:

      10;$ ;ODP;3344L0;32;     0;SH;1 ;       768.99

      10;LB;ERF;079J01;51;     0;9D;1 ;      -195.28

       

      When I try to modify the field list to accept a second character  in that field it appears the whole model loses it's place. I have tried adjusting each field by one and it doesn't seem to hold( possible bug ?)

       

      1. How do I adjust a field length and the starting point of a field.

        • Question for someone new to Monarch
          Olly Bond

          Hello rsullivan, and welcome,

           

          Hmmm - it looks like the 8th field was also modified, guessing by your sample.

           

          From what you say, there's one model that is used to create this delimited file, and then the model is opened again in Monarch?

           

          Or does the file arrive as the output from another system, and it's just meant to be Monarch'd to turn it into something useful?

           

          The last model, when you open the delimited file in Monarch - are you opening it as a Report or as a Database? It sounds like you're opening it as a report, and the "not seeming to hold" behaviour might be that you're using the floating trap.

           

          If you open the tutorial files weblog.prn and weblog.xmod, does that look a bit like what you're dealing with?

           

          Best wishes,

           

          Olly

           

          PS Monarch "processing" can get be a tricky beast to support, unless whoever set it up left you some clear documentation. I've fallen behind with my blog but there will be a post soon on how to document multi-project processes...

            • Question for someone new to Monarch
              rsullivan _

              Olly:

               

              Thank you for your help. I tried very hard to figure out the old code (and of course they didn't leave documentation) and just couldn't decypher it. I decided to just discard the old code and managed to get a new Model and code to run yesterday and get the report back into the producton scheduled. The report was down for a week and will run long tonight but I think I am out of the woods for now.