1 Reply Latest reply: May 15, 2014 10:14 AM by Olly Bond RSS

    How to suppress page breaks that are interfering with trapping

    MonUserCJ _

      Hello,

       

      I have a report in which sometimes the last digit of the zip code flows on to the next line. I have been able to successfully trap this overflowed digit by having the zip code field end on "None of the Above".

       

      However, there are dotted page-breaks interspersed throughout the document. They don't correspond with page headers because there appears to be only one page header and multiple page breaks.

       

      In cases where the last digit of the zip code is pushed past a page break, it is not being trapped. I seem to recall there being an easy way to suppress the page breaks, but I'm not finding it at the moment. Does anyone know what setting I can choose? I would greatly appreciate any advice that anyone can provide.

       

      Thanks.

        • How to suppress page breaks that are interfering with trapping
          Olly Bond

          Hello CJ,

           

          You can configure the Options > Input to set the Page Length to differ from the default 10o lines. The maximum is unfortunately hard wired to 254 lines, and Datawatch didn't seem very keen on introducing an option to suppress page breaks when I asked for this at the Vegas conference in May.

           

          In your case, it seems the report does have a page header, so if you trap this in a new template and and set the type of is to be Page Header, you should be OK, unless your report has pages that are more than 254 lines long.

           

          Hope this helps,

           

          Olly