2 Replies Latest reply: May 15, 2014 10:12 AM by elginreigner _ RSS

    CR/LF added to begin/end of file/fields

    elginreigner _

      I have a model that rips apart a report into 3 parts, simply, header, monthly and detail.

       

      Each part is a memo field. For testing purposes, I combined the fields into one large field and export it as a test file, fixed width. When I open the file, (notepad++), there are extra CR/LF at the beginning and end of file. Also, there is a tab delimiter before the extra values.

       

      Is this from the memo lines? Can I remove the extra CR/LF/tab?

       

      They are not padded fields, the option is turned off anyway. Ideas?

        • CR/LF added to begin/end of file/fields
          Olly Bond

          Hello elginreigner,

           

          Nice spot - I can replicate this in 10.5 Pro. I've not needed to export Memo fields to fixed-width text before but it does seem slightly odd behaviour.

           

          You can certainly get rid of the extra tabs - use the Monarch Utility that ships with Monarch (it's in the Monarch Program folder) and select the option "Prepare files for Monarch", then Replace all instances of the string /9/13/10 with /13/10. Getting rid of duplicate CRLFs is then just replacing /13/10/13/10 with /13/10.

           

          This can all be called from a batch file if you need to automate this.

           

          Hope this helps,

           

          Olly

            • CR/LF added to begin/end of file/fields
              elginreigner _

              Olly

               

              Thanks for the reply. It's not a normal setup for me, I need to insert data into the middle of the report. The memo fields worked perfect, they just had these side affects. I will only be running this model once a quarter. It won't be too much trouble to manually remove them.

              I tried to code every which way around this, I thought it was internal to Monarch, which is not the case.

               

              Oh well, thanks for confirming this.