3 Replies Latest reply: May 15, 2014 10:09 AM by Diony _ RSS

    Append Populating to Wrong Rows

    Diony _

      Hello,

       

      I have a model that is using multi rows.  I found that the lines 3 and 4 were not always present.  So I added an append with these rows.

       

      That did the trick as it put in these rows in the correct records.

       

      However, when the append does not exist it's placing these records in all of the other rows rather than leaving the blank.  It appears to be taking the latest value and insterting it until it comes to a true row.

       

      Hopefully this makes sense.

       

      Does anyone have any thoughts?

       

      Thanks.

        • Append Populating to Wrong Rows
          Data Kruncher

          Edit the append template and click the "Cleared by" button. Set the drop down list to the Detail template, and save the template. Please post a sample of your report if you're still having problems.

            • Append Populating to Wrong Rows
              Grant Perkins

              It sounds like your Append capture should only ever apply to a single record. If so you should be able to make it 'reset' for each record by making the trap you use include the entire detail record trap. Indeed often the only trap required will be the detail record trap duplicated for the append template.

               

              How you define the fields in the append may need some care depending on the report layout but if you are sure that what you currently have works correctly then the chances are you should be OK.

              • Append Populating to Wrong Rows
                Diony _

                Edit the append template and click the "Cleared by" button. Set the drop down list to the Detail template, and save the template. Please post a sample of your report if you're still having problems.[/QUOTE]

                 

                Data Kruncher...that worked perfectly.  Thank you so much for you help.