14 Replies Latest reply: May 15, 2014 10:09 AM by warlok RSS

    Finally got Monarch 10.5

    warlok

      Hi All,

       

      I finally managed to have purchased a copy of Monarch version 10.5 (up until now I was running version 8)

       

      But now installing the new version has bcome a nightmare. I tried to install the new version and the installation hung at 95% on 2-3 occassions. I could not get it past that point. So I tried to uninstall all versions of Monarch from the PC. * deleted correctly and then 10.5 Wouldn't fully uninstall. It's always listed in the windows add or remove program utility. I then tried to repair the install. The utility flashed by with no messages or information so fast. I'm pretty sure it failed to do anything. The interesting thing is after this point, any time I tried to reinstall the program fails to ask for the CD key. Up until this point it always asked.

      Again I've tried to install, and this time I'm getting all kinds of error messages. Most prevelant is one that says I cannot add the utilities into the current installation, as the product was installed in Secure Audit Trail Mode. Please get an Administrator to uninstall and reinstall this product. ( I had always chosen a full installation as the option) At this point I did call my admin over who temporarily gave me admin rights onthe system. But even with those rights this error message still came up. So I get booted back to the select components section on the install at this point and Utilities is not checked off. If I select utilities I always get the same error message. If I try and install without it, It runs through and bombs out on the Lesson Files with the following error message :

       

      Component transfer error

      Component Lesson Files

      File Group EngMonarchModelFiles

      File: \

      Error: The filename, directory name, or volume label is incorrect

       

      After this message it boots me right out of the install

       

      If I choose the install without the utilities and without the lesson files then It runs thorugh and states Maintenance Complete. and I can finish the install.

       

      The only problem then is, under program files/monarch folder I only see three folders in there Models, Program and Projects. No where is the executable setup for me to run Monarch.

       

      Has anyone else run into this?

       

      I should also mention that I'm running on Windows XP SP3 and have more than enough disk space, ram and processing power, although it's not a super fast system, it's more than enough to get the job done.

        • Finally got Monarch 10.5
          warlok

          I've now tried to reinstall version 8 back on my system. It too is crashing and hanging now at 97% of the installation. Whatever is causing the issue, is causing it to crash for both versions.

            • Finally got Monarch 10.5
              Olly Bond

              Hello Warlok,

               

              Well done on getting 10.5 - sorry to hear you're having upgrade problems.

               

              Whenever I've seen these, it's been fixable by two steps:

               

              1. Make sure you have the right version of .NET framework

              2. Empty the appropriate registry entries which refer to the old version

               

              Monarch support should be able to help you through this without any problem - did you try phoning them?

               

              Best wishes,

               

              Olly

                • Finally got Monarch 10.5
                  warlok

                  Hi Olly,

                   

                  Actually I sent an electronic ticket in. The first thing they mentioned is the .Net Framework may be corrupt. I'm trying to work on correcting that now and see if it helps. The good news is I did manage to get 8.0 back and working even though it's installation hung at the 97% mark. I tested it out against some projects I have worked on and it seems to be going okay. Gotta love PCs

                   

                  I'll let everyone know here as long as I can get it up and going.

                    • Finally got Monarch 10.5
                      elginreigner _

                      I too know the pain and their quick response to say .NET is corrupted. This is usually not the case, .NET gets updated more often than Monarch, so some users will run into issues.

                       

                      With the recent issue, I was given a complete listing of uninstalling/re-installing Monarch, hope this helps:

                       

                      1. Close all running applications.

                      2. Go to Start > Control Panel > Add/Remove Programs.

                      3. Choose “Monarch Pro” and then click the “Remove” button.

                      4. In Monarch Setup Maintenance program, choose the option “Remove”, and then click “Next”.

                      5. Proceed with the next steps and wait for the uninstall process to finish.

                      6. Once Monarch Pro is uninstalled, open the Registry Editor by selecting Start > Run and then type in “regedit”.

                      7. Delete the “Monarch Pro” folder located in the folders:

                      • HKEY_CURRENT_USER/SOFTWARE/Datawatch

                      • HKEY_LOCAL_MACHINE/SOFTWARE/Datawatch

                      8. Delete the folder “Datawatch Shared”, located in C:\Program Files\Common Files\.

                      9. Delete the “Monarch” folder under C:\Program Files\.

                      10. Reboot the machine.

                      11. Reinstall Monarch Pro.*

                        • Finally got Monarch 10.5
                          warlok

                          Thanks for the tip. I received the same message from Support.

                           

                          After uninstalling Monarch, It still left residual components of itself on the system. Add/Remove utility still shows on the system even after following all the steps. Removing .Net Framework caused a whole bunch of other issues. Net Framework failed to reinstall on my machine and would crash so I ended up getting Tech support here had to log on and try and correct the issue. At this point Tech support managed to crash the machine and I could no longer get to the log on screen. I've been without my computer now for about 4 hours. Tech support have returned it and thankfully did not have to reimage the machine, however; I can now log on and use it again.

                           

                          So after all that, I try to install Monarch Pro version 10.5 again. First time, failure. A message about being administrator and installing the utilities section pops up (I have administrator rights to the machine). Okay, Will try without that option. Second new attempt to install fails. This time I get the same error message over the lesson file stated in my first post. Okay, Will try a third and fourth time. This time the utility runs through the install and completes adding the program and the help files... except although the install program ran and was successful, no files were actually installed. No directory is showing up under program files on my PC.

                           

                          So after 3 days of fighting with Monarch Pro Version 10.5, I surrender. Sadly I can not justify taking more time battling this to install and I can't recommend it further to people at my work. It's back to the older version for me. Maybe even look for other software.

                           

                          If we can't get licenses for older versions and we get major headaches like this for newer version, I'm stuck between a rock and a very hard place.

                            • Finally got Monarch 10.5
                              RalphB _

                              Warlock,

                               

                              You could try the network version of Monarch.  We've been running the network version ever since V6 and had no problems.

                                • Finally got Monarch 10.5
                                  Olly Bond

                                  Hello Warlok,

                                   

                                  Don't despair - 10.5 Pro runs fine on our XP machines at work. We can even install it remotely onto users' machines where they don't have any admin rights. Can you get your machine re-imaged so you are starting from scratch with a clean PC (without any Monarch installed on it at all)? Or can you get hold of a spare "standard" PC from your company?

                                   

                                  Best wishes,

                                   

                                  Olly

                                    • Finally got Monarch 10.5
                                      warlok

                                      I've received other instructions on how to uninstall old versions of Monarch or bad installs. I ran through it and It's been successful in uninstalling Monarch completely. How can i tell?

                                       

                                      Well I can attempt to reinstall Monarch 10.5 and it's treating it like a brand new install, which is definitly progress. The only issue now is at 95% on the setup status, the setup.exe program seems to be hanging. I know from version 8 that near the end there is a stall as it sorts out the files and loads them onto the system, but.... After waiting 20 minutes, this seems a little excessive. CPU usage is 0-3%, there is no drive activity on the disk drive light. The Process for Setup.EXE is showing at 00 but the application is still showing as running and at least not showing "Not responding". Sadly though, if I can't complete the install, it's still not good.

                                       

                                      I'd love to be able to do a reimage, but I will lose a lot of custom programs and work which I would need to reinstall and setup again, etc. Not an ideal situation. This also would have an impact on us trying to install this out on the field.

                                       

                                      Being a test upgrade my progress is being monitored and everyone knows what is going on here. Each problem I hit isn't going over too well.

                                       

                                      But I do believe in progress.

                                        • Finally got Monarch 10.5
                                          warlok

                                          I think I've finally stumped first line support. Yay! :cool:

                                           

                                          Last reply back is they are having to consult over it. I suspect Someone is trying to figure out what happens at the 95% mark. I'm sure it has to do with unpacking and organizing the programs files into the correct placeing on the system. Something has made it hiccup and It's hung. I always wish in times like this that there is some sort of (hidden maybe) log. If you can find where in the install process things freeze up, you can battle the problem better. Without that (and most software I've seen is like that), you're having to guess.

                                            • Finally got Monarch 10.5
                                              warlok

                                              Okay Although the setup has stalled and it's stuck on 95% And while waiting for Datawatch to come back to me, I decided to check the files in the background. (because i can)

                                               

                                              And low and behold It seems to be setup correctly... at least I think so.

                                               

                                              Monarch Version 8 installed all files into a folder called C:/Program files/Monarch. the executable and all that went with it was stored in there.

                                               

                                              Monarch 10.5 seems to have created the C:/Program Files/Monarch folder and inside that folder is a link to the forums website, a readme.txt file and another folder called Program. Inside this Program folder is the monarch executable and the full program.

                                               

                                              On a hunch I tried to run it and it seems to be working. But I'm wondering is this correct or did it unpack incorrectly? Did the file structure change for Monarch?

                                               

                                              ANy other thoughts or ideas?

                                                • Finally got Monarch 10.5
                                                  warlok

                                                  Looks like I spoke too soon. If I try and execute old projects it bombs out. Ah well, The hope was fun while it lasted.

                                                    • Finally got Monarch 10.5
                                                      Data Kruncher

                                                      Of course existing projects should[/I] work properly, but what happens if you build a new one?

                                                        • Finally got Monarch 10.5
                                                          warlok

                                                          Okay. The file structure hasn't changed.

                                                           

                                                          After about 45 minutes, I had given up. Ejected the CD and started to close programs (I'd had to post issues here, send out emails to support and of course the windows explorer to see directory structure.) I decided to leave Monarch install to see what would happen. As it turns out, once I removed the CD, It still showed as running the application. But even stranger a few minutes later I started to see more activity and then the install jumped from 95% to 96%. I was totally shocked. Not only that, but it finished installing. And after a few qucick test it looks like it's working fine. Tested some old projects and they run without bombing out. The directory structure is still a little different and has me a little concerned, but again It seems to have been working so far. I guess I'll have to try and make time for a more complex test tomorrow.

                                                            • Finally got Monarch 10.5
                                                              warlok

                                                              I pulled a file into Monarch and created a quick method and project and it seemed to work fine. I'llhave to play around a little bit and see how the batch files will work to drive the actual program. I'm surprised that they work since the Monarch.exe program is now located in the main directory. There has to be a pointer set somewhere checkingfor that and redirecting it to the correct spot. I'm just unsure if that is true or not. I'm less worried about it now though.

                                                               

                                                              Thanks everyone for thoughts and suggestions. It looks like I'm good to go.