2 Replies Latest reply: May 15, 2014 10:09 AM by elginreigner _ RSS

    Monarch installation woes on Win2K

    Nick Osdale-Popa

      So, we have a Win2K machine that's been running Monarch V7. I got the bright idea (uh oh!) to install V10 on it. No go. V10 requires .NET Framework 3.0. You can not install that Framework on the Win2K OS. No problem, I'll just try V9.

       

      Well, the installation got to about 95% and just stopped. I let it sit for about 30 minutes and it didn't changed. So I cancelled the install. Monarch of course complained that the installation was aborted. I tried running it and it seem OK. That was until I tried installing the 9.01 patch. Got the warning that I must have V9 installed in order to add the patch. So I run a repair install on V9. It said it completed successfully, but the patch still gave me the same error.

       

      Fine. I'll just resort back to V7. However, now I can't uninstall V9. It says it was successful right away without doing anything. It's still there and it actually still runs. Windows add/remove software does not work either.

       

      The worry is that I don't trust the install. I have automated routines running on that machine and I fear that Monarch is going to start bombing out.

       

      What are my options? How do I get rid of V9?

        • Monarch installation woes on Win2K
          elginreigner _

          I got the following from Datawatch while working on another issue:

           

          1. Close all running applications.

          2. Go to Start > Control Panel > Add/Remove Programs.

          3. Choose “Monarch Pro” and then click the “Remove” button.

          4. In Monarch Setup Maintenance program, choose the option “Remove”, and then click “Next”.

          5. Proceed with the next steps and wait for the uninstall process to finish.

          6. Once Monarch Pro is uninstalled, open the Registry Editor by selecting Start > Run and then type in “regedit”.

          7. Delete the “Monarch Pro” folder located in the folders:

              • HKEY_CURRENT_USER/SOFTWARE/Datawatch

              • HKEY_LOCAL_MACHINE/SOFTWARE/Datawatch

          8. Delete the folder “Datawatch Shared”, located in C:\Program Files\Common Files\.

          9. Delete the “Monarch” folder under C:\Program Files\.

          10. Reboot the machine.

          11. Reinstall Monarch Pro.*