2 Replies Latest reply: May 15, 2014 10:09 AM by Olly Bond RSS

    Suppress (Null) from export

    crhowell _

      How can I suppress the string "(Null)" when exporting data?  I prefer it just show a blank field instead of "(Null)".  Is this possible?

       

      Service  Admit Date   ACC

      NNB      (Null)        F

      SUR      (Null)        B

      INT      10/18/2010    A

      MED      10/18/2010    I

      MED      (Null)        F

      /CODE

        • Suppress (Null) from export
          elginreigner _

          Under the menu Options>View, change the "display null values as" to a blank or whatever your preference is.

            • Suppress (Null) from export
              Olly Bond

              Hello Charles, hello Elgin,

               

              If you export to text, then either Options > View as suggested should do the trick, or you can easily workaround with a calculated field. Exporting to Excel is much tricker - Monarch will try to write an Excel file with one column full of dates, and whether your options specify it should write in "", or "-", or (null) or whatever you specify, Excel will interpret it as a bad value in a cell which should be a date, and it will show as NULL.

               

              The easiest workaround is to create a character calculated field using if(isnull(field)=1;"";str(field)), and hide the original field, and then export that.

               

              Best wishes,

               

              Olly