3 Replies Latest reply: May 15, 2014 10:09 AM by drobert _ RSS

    Extra Character At End of File

    Diony _

      Good Morning,

       

      I am currently using Monarch to export a file in a .csv format.  Everything is working fine except the last line contains a weird character.  Probably an end of file character.  Is there a way to have this removed?

       

      Thanks in advance.

       

      Last 2 lines example:

       

      "M**********A","M****************************3",20100930,0

       

       

      note - I've starred out sensitive data.

        • Extra Character At End of File
          joey

          Options->Export & Clipboard, Text files tab, uncheck the option for "Append DOS end of file character(x1A)".

            • Extra Character At End of File
              Diony _

              Thank you very much.  That did it.  Not sure I ever would have found that.

              • Extra Character At End of File
                drobert _

                Wow, this is great timing!!!:D

                 

                I was just going to complain:rolleyes: about the same thing!  You see, I use an initial scan of the report and create a text file contain information I want to use to filter for the next pass.  The problem I was having was that in my batch file I was checking if the value was numeric (because I wanted to skip over the column title and the EOF marker) but for some reason the EOF marker was considered numeric (test: the value was able to successfully be multiplied by 1) and therefore was being used in the batch for the parameter of the second pass... what a mess:eek:.  Now that I have modified it to not add the EOF marker, my batch works great.

                 

                Thanks Joey!

                 

                PS Sorry Diony for the piggyback:(.