3 Replies Latest reply: May 15, 2014 10:07 AM by Gareth Horton RSS

    Another "User-Defined Functions" problem

    gschneyer _

      ok, I've tried to read the past posts in regard to the "Unable to Expose User-Defined Functions from the following models: Default" error message. Tried running the MonarchU program, but no change. So I'm missing something, hmmm...

       

      Starting at the beginning, I created a model, followed the book and ran it fine on my PC. The program is supposed to be used by four other members of the office; accounting, accounts receiveable, etc. So I copied the file to each of the PCs in the Documents&Settings\All Users\Monarch\Models directory. So as to not confuse them I took all the tutorials and put them in a seperate Tutorial directory.

       

      So now when I run the model I receive that error message. I tried to use the MonarchU, but there's several options, not sure which to use.

       

        - Copy models or projects from one location to another

       

      I used that, thinking maybe my just copying the file from one to the other didn't help, still no change though.

       

        - Convert text models or projects to XML

        - Manage external references in XML models or projects

        - Manage authors and descriptions in XML models or projects

        - Purge audit trails in XML models or projects

        - Prepare files for Monarch (Replace, Insert line breaks, EDI)

       

      So which one should I use and how, the book doesn't explain MonarchU, at least from what I can see? Thanks.