4 Replies Latest reply: May 15, 2014 10:07 AM by Olly Bond RSS

    Multi Column Region - Stop at end of report?

    reeves

      Hello all,

       

      I'm having a issue with the Multi Column Region, which I think should be possible with Monarch. We have a SAP report which exports a table having our productgroups on top, the ledgers on the left and offcourse the values for each productgroup underneath the right column.

       

      Like:

      | |

      |   |

       

      Instead of on this forum, the data is underneath each other (so no need to use floated traps).

       

      As I need my output to be

      [some ledger][value of 10.00]

      [some ledger][value of 90.00]

       

      I'm using the MCR function in Monarch Pro v 10. This works great for the first page. But as the second page doesn't have the table header, all values of page 2 are reported as .

       

      To avoid this problem I think I should change the Boundaries (vertical) Stop at to 'End of report' , but that option isn't there. Also changing the paper size doens't do the trick.

       

      I've also tried to make a dummy trap at the last line of the last page, but that also won't work as Monarch still stops at the bottom of the page (and continues on the next page with .

       

      I hope the problem is clear and that some of you know how to deal with it.

       

      Thanks in advance,

       

       

      Koen

        • Multi Column Region - Stop at end of report?
          Olly Bond

          Hello Koen,

           

          Thanks for posting. It might be possible to get a fix by changing a parameter in the SAP report - perhaps to put extra empty (or nearly-empty) lines in between data entries.

           

          You'll certainly be able to overcome this with a two pass approach, where you take the appends in a separate model to the detail, but there ought to be a one pass fix.

           

          Is it possible to mail me or post here a sample of the report - ideally with over 255 lines lines of detail? I should be able to get you a fix over the weekend.

           

          Best wishes,

           

          Olly

            • Multi Column Region - Stop at end of report?
              Olly Bond

              Hello Koen,

               

              I just mocked something up in Notepad to test in v10.5 Pro, and I can confirm the behaviour you report. It looks like a bug to me - certainly it's not intuitive Append behaviour. I made a file with 300+ lines of:

               

                      | PG1   | PG2  

              SL1     | 10    | 90   

              SL1     | 10    | 90   

              SL1     | 10    | 90   

              SL1     | 10    | 90   

              SL1     | 10    | 90   

              SL1     | 10    | 90   

              SL1     | 10    | 90   

              SL1     | 10    | 90   

              SL1     | 10    | 90   

              SL1     | 10    | 90   

              SL1     | 10    | 90   

              SL1     | 10    | 90   

              SL1     | 10    | 90    /CODE

               

              Testing it with a calculated field based on Column() confirms that it's in the MCR of the detail that things are going wrong. To see this, make three calculated fields called Column, Page and Line using the Monarch functions Column(), Page() and Line(). Sort the data in Page, then Line, then Column order.

               

              You see:

               

              1     1     1      PG1   | PG2     SL1     10

              1     2     1      PG1   | PG2     SL1     10

              1     2     2      PG1   | PG2     SL1     90

              1     3     1      PG1   | PG2     SL1     10

              1     3     2      PG1   | PG2     SL1     90

              1     4     1      PG1   | PG2     SL1     10

              1     4     2      PG1   | PG2     SL1     90

              1     5     1      PG1   | PG2     SL1     10

              1     5     2      PG1   | PG2     SL1     90

              1     6     1      PG1   | PG2     SL1     10[/CODE]

               

              The page break is messing up the MCR badly, and after 198 entries, so from the start of page 2, the column values revert to all being 1.

               

              The only fix I can see for the moment is to prep the data using a first model that artificially inserts clean page breaks and replicates the append on each page. You can do this using Page and Append (the PG1 | PG2 data) as hidden key fields to get:

               

              Page: 1     

              Append:  PG1   | PG2     

              SL1     | 10    | 90     2

              SL1     | 10    | 90     3

              SL1     | 10    | 90     4

              SL1     | 10    | 90     5

              SL1     | 10    | 90     6

              SL1     | 10    | 90     7

              SL1     | 10    | 90     8

              SL1     | 10    | 90     9

              SL1     | 10    | 90     10[/CODE]

               

              (the line field is an item so that duplicate data values aren't lost). Export that summary as a fixed width text and then Monarch's MCR should trap it OK, as you'll have clean page breaks and appends on every page.

               

              Sorry it's a two step process, but these can be automated, and don't hesitate to give us a shout if you need any help with that.

               

              Best wishes,

               

              Olly

              • Multi Column Region - Stop at end of report?
                reeves

                Hello Olly,

                 

                Thanks for your replies as well as all your effort.

                 

                The fix however is quite simple and I'm almost embarrassed :o that I didn't think about it.

                 

                When I go to Input -> Options and change the "Force page break after" to the number of lines in the report, the problem is fixed...

                 

                So do your advantage with this and thanks again for the help.

                 

                Have a great weekend!

                 

                 

                Koen

                  • Multi Column Region - Stop at end of report?
                    Olly Bond

                    Hello Koen,

                     

                    You're quite right, that changing the value in the Page Break length field in Options Input does fix it.

                     

                    That's odd - this is defaulting to breaking at 100 lines - but somehow to make the MCR work you need to change it.

                     

                    Well, that's certainly easier than running two models!

                     

                    Best wishes,

                     

                    Olly