4 Replies Latest reply: May 15, 2014 10:06 AM by Grant Perkins RSS

    Export overwriting entire spreadsheet

    RalphB _

      I just started experiencing a problem when I try to overwrite a tab in an Excel spreadsheet instead of just overwriting that tab, it overwites the entire file!  This is extremely frustrating when the other tabs contain several days worth of data. :mad:

       

      This model worked perfectly when I overwrote the same tab yesterday without deleting all tabs but today it does!

       

      Anyone else experiencing similar problems? Did not have this problem with other versions.

       

      V10.5 Pro.

        • Export overwriting entire spreadsheet
          Data Kruncher

          Are you exporting to an .xls, an .xlsx or an .xlsm file? I suspect .xls.

           

          Which driver is the model using?

           

          How many times (ballpark) have you exported to the same file? < 10? > 200?

            • Export overwriting entire spreadsheet
              RalphB _

              Sandy,

               

              I am exporting out to Excel 2003 sp 3 and exporting out with the option Excel 97 + (Monarch V8).  We haven't upgraded to Office 2007 yet.

               

              On this model and script, I just started to want to overwrite a tab after seeing that it wasn't exporting anything to it when it should.  If the tab has data, it should append and does successfully.

               

              I was able to successfully overwrite just the one tab yesterday with no problem but today, when the person who will be doing this on a regular basis experienced this problem.  I tried it myself and it worked fine but when she tried it again, same problem.  So I tried it and had the same problem with the script.  So I tried to to it manually and it did the same thing even after I rebooted my machine!

               

              Now, I am doing similar exports with other models with no problems so this has me completely baffled.  :confused:

               

              Any Suggestions Sandy?

                • Export overwriting entire spreadsheet
                  Data Kruncher

                  Hmm... just a shot in the dark here as nothing really sounds problematic - aside from the final outcome that is!

                   

                  Might be a corrupt model. It's very rare, but it can happen. Can you rebuild the model/project in less than 15 minutes or so?

                   

                  Also, I would highly recommend always scripting exports by project file with defined exports (even if there's only one defined). They seem to be more reliable when scripting export processes. Don't know why that is, but that's how it seems, IMHO. Also, there's nothing easier than adding a /pxall .