6 Replies Latest reply: May 15, 2014 10:06 AM by Olly Bond RSS

    Unable to upgrade to v10.5

    D McCarthy

      I have recently upgraded to Monarch v10.0 but have experienced several bugs so.  After viewing the website i decided to download the latest patch (v10.5).

       

      When attempting to install this patch an error message stating "Monarch is not installed on this machine".

       

      Please advise as it is critical that this is resolve asap due to it affecting 50-100 machines.

       

      Regards

       

      David

        • Unable to upgrade to v10.5
          Data Kruncher

          Hi David,

           

          Not trying to be funny, but as you didn't indicate specifically (and assuming that you're intending to update a network installation), did you apply the proper update patch (workstation vs. single user), and if so, did you apply the Server Admin update first?

           

          Kruncher

            • Unable to upgrade to v10.5
              D McCarthy

              Thanks for your reply and it's a valid question!

               

              I believe we have single user licenses and out of pure curiosity after the patch failed to install i actually tried all available versions iin the following order:  single user / network / workstation.

               

              Perhaps the code that validates the version number is looking for something that is missing from the registry?  Do we know where the registry entry should be?

               

              Kind Regards

               

              David

                • Unable to upgrade to v10.5
                  RalphB _

                  David,

                   

                  A quick and easy way to tell if you have a single user v network is to check the files on your hard drive.  Go to C:\Program Files\Monarch\Program\ and check the files there.  If there are only 4 files like on mine, then you have a network version.

                   

                  If that is the case, the network upgrade filesneeds to be downloaded and installed on the network server first along with the workstation upgrade files.  Once that is done, then you need to install the workstation onto each users machine.

                   

                  HTH,

                   

                  Ralph

                    • Unable to upgrade to v10.5
                      D McCarthy

                      Hi Ralph,

                       

                      Thanks for confirming how to differentiate versions.

                       

                      I'm 100% sure we have single user licenses - i only tried the other patches out of frustration before posting for help

                        • Unable to upgrade to v10.5
                          Grant Perkins

                          David,

                           

                          Have you contacted UK Technical Support yet? If not I would be tempted to do so.

                           

                          FWIW I upgraded from 10 to 10.5 with no problems that I can recall.

                           

                          However sometimes existing installations might get into a funny state that means they no longer fit with the expected start point for the upgrade installation. It does sound like an odd message for a stand alone installation though. I assume you did not delete the existing V10 installation first?

                           

                          Might there be some discrepancy with user permissions on the machine? Does your login provide the correct degree of access at the operating system level? (I'm assuming you will answer yes but these types of basic questions are all too easily overlooked as possible, unexpected, could not possibly be the case, causes of installation issues so I tend to pose them anyway.)

                           

                          Presumably you had a go at the 10.5 upgrade a couple of times before trying the other patches? Did you also try on a different machine? (It sounds like you may have the choice of a few to play with!)

                           

                           

                          HTH.

                           

                           

                          Grant

                            • Unable to upgrade to v10.5
                              Olly Bond

                              Hello David,

                               

                              It does strike me as a little odd to have so many desktop licences. Do all the users need to edit or build models? If it's just a matter of delivering Excel data to users, you might find it easier to manage with a DataPump server (delivery via network, FTP, email or Sharepoint) or with BI Server (delivery via web browser)? Auditing the data when all the end users have a chance to modify the models would be tricky...

                               

                              Best wishes,

                               

                              Olly