5 Replies Latest reply: May 15, 2014 10:05 AM by Data Kruncher RSS

    Data Translation Issues from Migrating Ver6 to Ver9

    LJordan _

      Hello,

       

      We are currently in the process of migrating off of Ver6 to Ver9 but we have run into an issue with how the data is being translated, which it could be the character set settings,.

       

      The following is occuring

       

      In Ver6, blank characters are being translated in the database as (NULL)

       

      In Ver9, blank characters are being translated in the database as 1 blank character space

       

      In Ver6, the character ' is being translated as `

      In Ver9 the character ' is translated as '

       

      Has anyone come across this issue? We are using a Sybase database with ASE/OLE connection

       

      Thanks in advance

        • Data Translation Issues from Migrating Ver6 to Ver9
          Olly Bond

          Hello LJordan,

           

          From your post, I get the impression that you are using DataPump to take reports from an external source, and to populate data in tables in Sybase using OLEdb? I presume that you've migrated all your v6 .mod files to v9 .xmod files using the Utility?

           

          You might want to check in Monarch the Options around ASCII and ANSI - as this might affect the ' character issue. The null/space issue I'm not sure I can diagnose. We've noticed also that DataPump v9 is sensitive to server changes in regional options - so it's possibly worth looking in the registry to see if something's changed there.

           

          Best wishes,

           

          Olly