3 Replies Latest reply: May 15, 2014 10:04 AM by ChienTan _ RSS

    Monarch v4 - upgraded to v10 (Problems)

    ChienTan _

      Hi all,

       

      I've never really had any experience with monarch.

       

      However i've been set the task of upgrading Monarch from version 4 to 10.

       

      I've got my head around the batch files and what not, where the problem appears to be occuring is in the models.

       

      The models currently in place are models created from Monarch version 4 (i.e. *.mod). I understand that Monarch version 10 uses *.xmod model formats. Is there any way of updating these models so they work in version 10? BEcause at the moment Monarch isn't exporting any data to the specified excel documents.

       

      Would appreciate some help and feel free to let me know if i need to provide any further information.

       

      Thanks all.

        • Monarch v4 - upgraded to v10 (Problems)
          ChienTan _

          I've just found out about the convert utility.

           

          However, I'm still running into problems of Monarch producing nothing?

           

          I've made changes to the references in the batch files. (i.e. if it was previously the file.mod i've changed it to thefile.xmod).

           

          *Edit

           

          I thought i should include one of the batch commands:

           

          "%Monarch%" /rpt:"%FILEFOLDER%\file1.txt" /mod:"%MODFOLDER%\file1.xmod" /exp:"%FILEFOLDER%\file1.xls" /T

           

          I know for a fact that Monarch is opening. However it doesn't appear to be opening the text file nor running the xmod with it. The file1.xls file is therefore being left blank.

           

          I'm completely new to monarch, so appreciate any advice!

           

          Thanks guys!

            • Monarch v4 - upgraded to v10 (Problems)
              Grant Perkins

              Hello ChienTan and welcome to the forum.

               

              Have you tried one of the scripts pointing explicitly to the folders you need to use in order to see what happens? Any different to the posted script results?

               

              For completeness you may also want to check out the Options settings for exports, in particular exports to Excel, if you have not already done so. Just to make sure the settings are as you need them to be.

               

              There is a reasonably comprehensive section in the Help file related to Commands and batch processing scripts. That may suggest some ideas to experiment with.

               

              You might also consider creating a new script for one of th processes using the 'Excel with Monarch' batch script generator and then comparing the results of that script with those existing scripts you need to upgrade.

               

              http://********************/tips/monarch-batch-file-generator[/URL]

               

              HTH.

               

               

              Grant

                • Monarch v4 - upgraded to v10 (Problems)
                  ChienTan _

                  Hi grant!

                   

                  Thanks for the welcome.

                   

                  What I'm having trouble doing, is exporting the data from the report to the table.

                   

                  All that appears to be exported is the field names, and not any of the actual data. Do you have any ideas?

                   

                  -- Solved the problem!

                   

                  For some reasons, the old model isn't working? I've gone and created a new model instead.

                   

                  I'm running into a problem of the order of the fields being a bit out of synch?

                   

                  The fields need to be exported into the excel document into a specified order.... In the "table" window they appear to be in the correct order, however once in excel they're a bit jumbled up...