5 Replies Latest reply: May 15, 2014 10:04 AM by CTINighthawk _ RSS

    Remove 'Tick' ( ' ) from Summary to Excel

    CTINighthawk _

      Hi

      I am trying to remove tick ( ' ) in Excel after I exported from Summary.

       

      Can you help? :confused:

        • Remove 'Tick' ( ' ) from Summary to Excel
          Data Kruncher

          The best way to handle this would be to remove the single quote from the values in the field that you're summarizing.

           

          You can do this in the Table window by building a new calculated field to handle the work. To remove the quote from Field1, for example, use this formula for your new Field2:

           

          Strip(Field1,"'")[/CODE]

           

          This uses a single quote enclosed with double quotes.

           

          Now in the Summary that you're exporting, replace the reference to Field1 with Field2.

           

          HTH,

          Kruncher

            • Remove 'Tick' ( ' ) from Summary to Excel
              Olly Bond

              Hello Nighthawk,

               

              Perhaps your tick character is your version of Excel's way of suggesting that a character field is numeric or vice versa? In my version, I get a small green triangular tag in the top left of the relevant cell. Excel is notorious - see many threads here - for thinking that number-like strings such as 0123456789 are not strings but numbers and suggesting they should be 123456789.

               

              You can also (in Monarch v9 or 10) export summaries to include subtotals as formulae instead of values - perhaps your Excel is defaulting to indicating cells with formulae by showing a tick?

               

              Best wishes,

               

              Olly

                • Remove 'Tick' ( ' ) from Summary to Excel
                  Data Kruncher

                  Hi Nighthawk, and welcome.

                   

                  I suspect that as you're profile indicate you're using V7, this is related to the current Excel driver in use. Go to the Options menu, Export and Clipboard item and for the XLS file, select the highest available Excel version driver from the list.

                   

                  I found an [URL="http://www.monarchforums.com/showthread.php?t=610"]older post[/URL] than indicated that it may be related to an old MS Jet issue.

                   

                  If neither the above nor the thread provide a good solution for you an upgrade from V7 might be in order.

                   

                  Good luck,

                  Kruncher

                    • Remove 'Tick' ( ' ) from Summary to Excel
                      CTINighthawk _

                      Thanks for your help.

                       

                       

                       

                       

                      Hi Nighthawk, and welcome.

                       

                       

                       

                      I suspect that as you're profile indicate you're using V7, this is related to the current Excel driver in use. Go to the Options menu, Export and Clipboard item and for the XLS file, select the highest available Excel version driver from the list.

                       

                      I found an [URL="http://www.monarchforums.com/showthread.php?t=610"]older post[/URL] than indicated that it may be related to an old MS Jet issue.

                       

                      If neither the above nor the thread provide a good solution for you an upgrade from V7 might be in order.

                       

                      Good luck,

                      Kruncher[/QUOTE]

                    • Remove 'Tick' ( ' ) from Summary to Excel
                      CTINighthawk _

                      Thanks for your help:)

                       

                      Hello Nighthawk,

                       

                      Perhaps your tick character is your version of Excel's way of suggesting that a character field is numeric or vice versa? In my version, I get a small green triangular tag in the top left of the relevant cell. Excel is notorious - see many threads here - for thinking that number-like strings such as 0123456789 are not strings but numbers and suggesting they should be 123456789.

                       

                      You can also (in Monarch v9 or 10) export summaries to include subtotals as formulae instead of values - perhaps your Excel is defaulting to indicating cells with formulae by showing a tick?

                       

                      Best wishes,

                       

                      Olly[/QUOTE]