5 Replies Latest reply: May 15, 2014 10:04 AM by Paul P RSS

    Getting Memory Error when opening DB

    Paul P

      I recently ran the windows update including the KB954430 Security UPdate for MS XML Core Service Pack, and now whenever I try to Open a Database in Monarch 10 it will generate a memory error and shut itself down. 

       

      Has anyone experienced this and if so, any idea how to fix?  I tried running the MS Jet 4.0 SP7 udpate that is noted on the FAQ page, which points to the MS Jet 4.0 SP8 update.  When I tried to run it told me I already had a newer version.

        • Getting Memory Error when opening DB
          machildn _

          I'm getting the same thing .... haven't solved it yet

            • Getting Memory Error when opening DB
              Paul P

              It appears that if a project contains external lookups to databases, it will work.  If however you select "Datebase" "External" lookups, or "File" "Open Database" you get the memory error.  Can Monarch tech support let us know what files are accessed during that process?

                • Getting Memory Error when opening DB
                  Grant Perkins

                  Paul P, machildn,

                   

                  Have you been in contact with Monarch Tech support directly?  If not it would seem like a good thing to do for a technical issue of this type. I would guess that there are enough variables in the mix that not everyone would be seeing the problem or perhaps, not exactly the same problem.

                   

                   

                  Grant

                    • Getting Memory Error when opening DB
                      Paul P

                      Tech support suggests uninstalling all .net framework and reinstalling.

                       

                      Specifically, start with a cold boot.

                       

                      Unistall ALL versions of the .net framework.

                       

                      Cold Boot.

                       

                      Reinstall .net 3.5 which will bring install all versions.

                       

                      Cold boot.

                       

                      Reinstall Monarch.  I'll report back after giving this a try.

                        • Getting Memory Error when opening DB
                          Paul P

                          Per the suggestion from the Monarch Support team, I first uninstalled all versions of the .Net framework from my PC.  I then uninstalled Monarch.  After a cold reboot, I installed the .Net 3.5 SP1 package found on Microsoft's website.  I then ran the suggested updates, and had the security update for .Net 3.5 SP1 fail. 

                           

                          I then reinstalled Monarch 10 and tried to access the database and got the memory error.

                           

                          Suspecting the failed update had messed up the .net framework, I went back and reinstalled the .net 3.5 SP1 package selecting repair. 

                           

                          Once this completed, I was then able to open databases.  At least on my PC, there appears to be something about the security update for the .Net 3.5 SP1 package that will not allow it to properly install, and thus was messing up the .net framework.

                           

                          So, if you are having this issue, I would suggest reinstalling the .Net 3.5 SP1 package, selecting "repair" and seeing if that resolves the issue.  If that does not, then I would go through the uninstall of all .net versions, followed by a reinstall of the 3.5 SP1 package, however I would avoid the latest security update for the .net 3.5 SP1 package.