4 Replies Latest reply: May 15, 2014 10:03 AM by Data Kruncher RSS

    Export to Excel

    RalphB _

      We have finally upgraded to Monarch 10 Pro and I like what I've seen so far.  I'm having a problem though. 

       

      I'm opening up an Excel spreadsheet in Monarch ok but when I try to overwrite an existing tab in a spreadsheet the export fails.  The spreadsheet I'm trying to overwrite has more lines than what I'm exporting and the column headings are all the same.  The export message that pops up after says it exported OK but it doesn't.  When I try to overwrite a tab that has fewer lines or is blank I have no problem.  It is just when it has more lines.

       

      I get the same results if I do this manually or run it through a script. :confused:

       

      Now it did run fine under version 8 and 9 and I can run it that way but the person who does this on a daily basis just has V10.  Has anyone else experienced this problem or is this a bug?

        • Export to Excel
          Data Kruncher

          Good news and bad news, Ralph. The bad news is that I can't duplicate your problem scenario. I've been at it for a half hour trying every different combination of Excel driver and output version. The good news is that it just works, but I do know that's not good news for you.

           

          How many records are in the existing file, and how many are meant to be exported? Are you exporting to xls, xlsx or xlsm files?

           

          Are the formatting and advanced features enabled? Does it work if you uncheck those options?

           

          I'm tempted to recommend (re)installing the .Net v3 patch.

           

          If you're still struggling with it then you might want to contact Tech Support directly. Let us know the results if you do.

            • Export to Excel
              RalphB _

              Thanks Sandy for trying.

               

              I forgot some background info.  We are all running XP Pro for an O/S and are using Excel 2003.  We have .Net3 installed.

               

              As for the spreadsheet, one of them had approx 800 lines and we tried to overwrite it with approx 500 which it said was successful but wasn't.

               

              This is all happening on a co-workers machine.  I haven't been able to run it on V10 on my machine because I'm having some problems with it right now so it may just be his machine.

               

              He is out today but I was thinking what excel output option in Monarch he is set to.  I'm thinking he is set for Excel97 + Monarch V9.  When I run it on V9 I have it set for Excel 97 + Monarch V8.  The original file was exported out using the V8 export setting. That may be the issue.

               

              Any how, I'll have him change his export settings tomorrow and see if that is the fix.

               

              I have posted a message on Tech support site for my problem and am patiently waiting to hear back.  I think it's an installation problem.

               

              Thanks again Sandy.