1 Reply Latest reply: May 15, 2014 10:03 AM by Grant Perkins RSS

    Incorrect data being filtered

    Lynette _

      Hi,

       

      Have been successfully working with a monarch model since the past few years (3 or more) and it has always generated the correct results until the last week. Not sure what is going wrong but the filters refuse to generate the correct and desired output i.e. some filters work well..However all filter using the data which is a calculated field just do not work right. I honestly tried everything other than recreating the model (which is gonna be really time consuming again) so any help / advice will be greatly appreciated.

        • Incorrect data being filtered
          Grant Perkins

          Hi Lynette,

           

          Not much to go on  - presumably because you have no idea about why this problem should arise. So first let's consider how things might change.

           

          Have you run any Monarch Updates?

          Have you had an MS Windows updates that might be relevant?

          Has the source report/database/data changed in any way?

          Could any data change have affected the calculated field?

          I note your profile indicates that you had V7 and V8. Is that still the case? If so is the problem occurring in both versions?

          What does the calculated field do when calculating?

          Has the model changed?

          Has the model been edited for any reason?

          Can provide an illustration of the data and filter for which the filter still works and also for which the filter does not work?

          Do you have a archive copy of the model?

          /LISTThese are some ideas about things that could be considered and checked that MIGHT lead to a better understanding of what is going on.

           

          Unless you (or someone else) have been actively editing the model or making other changes to Monarch I would firstly consider whether the source has some changes.

           

          If the model HAS been edited, even if nothing to do with the problem filter, testing any earlier archive version you may have could be useful.

           

          In 10 years of using Monarch I have come across some corruption of the model file (leading to unusual processing) about 3 times - always when beta testing and pushing the functionality a long way between model file saves. On each occasion I suspect the problem was related to being at the limits of the machine's memory and the interaction between memory handling and writing cache memory files to disk - so basically an operating system type of issue. The result was that the Models looked right on screen and worked for most functions BUT some parts of the model failed.

           

          Reviewing the model file as a text document suggested that some instruction lines had been written back into the wrong place in the file and changed its structure and might, therefore, lead to incorrect interpretation when processing.

           

          In the absence of a complete understanding of how the model sections should be constructed in the model file I decided the only safe way to re-create a working model was from a previous version or backup or to start afresh and build a new model file.

           

          However I must stress that this is a VERY VERY RARE event and I have not had such a problem at all in recent years. I mention it only because, as a last resort, it may be worth considering.

           

          HTH.

           

           

          Grant