2 Replies Latest reply: May 15, 2014 10:02 AM by Ginny2222 _ RSS

    Trapping Data

    Ginny2222 _

      Hi all,

      I'm new to Monarch so forgive me if I'm asking a question that has been answered before.  I have looked through some of the threads but can't see anything on this.  I can output my report from SAP in various different formats. I am having trouble with the trap.  I can build a trap, but when I substitute a new report I can't use the same template because a number of the fields have a variable width.  I have tried using the float, but without success.  There is one format csv which outputs the data with a line character | between each column, but I am having no success in using this as a trap character.  Is there any solution?

      Ginny

        • Trapping Data
          Data Kruncher

          Hi Ginny, and welcome to the forum.

           

          I think that you have a couple of options, given that you have v9 Pro.

           

          1) Open the CSV file with the Open Database... menu, specifying the | character as the field delimiter. This may be your easiest approach.

           

          2) You're having trouble trapping on the | characters because that character is one of Monarch's default trap characters, representing the "Numeric OR". So it's doing its proper job, but it's not looking for | characters in the position you specify. But by going to the Options, Input... menu you can select the Alternate trap characters instead of the Standard one. Then using a | character will trap | characters in the data, as you intended.

           

          HTH,

          Kruncher

            • Trapping Data
              Ginny2222 _

              Hi Kruncher,

              I have followed your instructions (I think).  I'm trying method 2 at the moment - I changed to the alternative trap chars, and have put the character above the trap line, once I click on the Floating Trap option, I'm still getting the message Numeric OR not allowed.

              Thanks

              Ginny