1 Reply Latest reply: May 15, 2014 10:02 AM by db3215 _ RSS

    Unattended installs of Monarch

    db3215 _

      We are attempting to package Monarch 8.0 to deploy as needed to our users. The manual installation procedure so far has required that Monarch be installed as the user with admin rights (temporarily granting admin to user, install Monarch, then remove them from admin). Otherwise, while Monarch itself works fine, the "Monarch Utility" app returns the error "Cannot open file MFWFIL32.DLL. File is missing or version is incorrect."

       

      I've tried granting Users Full Control to entire "C:\Program Files\Common Files\Datawatch" folder and its contents, including the problematic DLL, as well as the entire Monarch folder and the Datawatch registry key tree, but the error persists. The only way it seems to work is if it is installed as the user with administrative rights, and doing that doesn't work so well with unattended installs.

       

      Any help would be appreciated. Thanks.

        • Unattended installs of Monarch
          db3215 _

          Thanks Todd! I had seen one of the earlier posts about this and found that setting inheritable perms for the DLLs didn't help, but one of Gareth's suggestions in another thread resolved the problem... the key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\Monarch.exe

          ... was to blame. Changing that key so it was readable by all, fixed it.