4 Replies Latest reply: May 15, 2014 10:00 AM by tomkrier _ RSS

    File extentions for Input files

    Jay Dutta

      Hi,

       

      We are in the process of migrating our tasks from Datapump 5x to 7x; instead of copying the dpf's we thought of recreating the processes afresh;

       

      the input files do not have any extension, so while creating the xprj file, in the input section the files get added with dat;prn;rpt;txt extensions and then the process fails when run;

      but if i rename all inputs into files with txt extensions, the process works; this was never a problem with datapump 5x (when dpf files were being made);

       

      is there a work-around or solution?

       

      thanks a bunch in advance,

      Jay

        • File extentions for Input files
          Gareth Horton

          Jay,

           

          It looks like the conversion utility does not deal with this situation as well as it should.

           

          You can avoid the step of giving them a txt extension by just going into the Input Tab of the project with XPRJEditor and doing a single click on the pathfile specification and manually changing it to something like C:Inbox1.

           

          That will then process any files in that folder, whether they have an extension or not.

           

          Of course you can do other wildcards like b. to process all files beginning with b (with any or no extension) and so on.

           

          Gareth

           

          Originally posted by sjdutta:

          Hi,

           

          We are in the process of migrating our tasks from Datapump 5x to 7x; instead of copying the dpf's we thought of recreating the processes afresh;

           

          the input files do not have any extension, so while creating the xprj file, in the input section the files get added with dat;prn;rpt;txt extensions and then the process fails when run;

          but if i rename all inputs into files with txt extensions, the process works; this was never a problem with datapump 5x (when dpf files were being made);

           

          is there a work-around or solution?

           

          thanks a bunch in advance,

          Jay /b[/quote]

          • File extentions for Input files
            Jay Dutta

            thanks Gareth for your reply;

            your solution works but only when i feed as input files located on the server;

             

            both the input and output fail if they are in some other machine (accessible thru network, permissions are enabled for full control including read, write, modify, delete etc);

             

            is there something i am missing out?

             

            thanks again in advance,

            Jay

            • File extentions for Input files
              Gareth Horton

              Jay

               

              I think this may be due to the user credentials of the Datapump service.

               

              The service is called Monarch Data Pump 7 Service.

               

              Go to the log on tab and check that it is running under a user account that it has the necessary access rights to the systems in question.

               

               

              Note that the Local System account will not have access to any remote systems, mapped drives etc.

               

               

              Gareth

               

               

              Originally posted by JAY DUTTA:

              thanks Gareth for your reply;

              your solution works but only when i feed as input files located on the server;

               

              both the input and output fail if they are in some other machine (accessible thru network, permissions are enabled for full control including read, write, modify, delete etc);

               

              is there something i am missing out?

               

              thanks again in advance,

              Jay /b[/quote]

              • File extentions for Input files
                tomkrier _

                We have the same issue where are reports come down with no extension.  All we do when we edit the project file is when you point it to the location.  When you browse to the file it will give you this: D:MonarchImportFiles ep001.dat;prn;rpt;txt

                just highlight the location and delete from the period on back like so.

                D:MonarchImportFiles ep001

                 

                This will work!