4 Replies Latest reply: May 15, 2014 10:00 AM by Dee Moore RSS

    Random errors in jobs

    Bill Tilghman

      I'm running 7.0 Datapump and with about 60 jobs daily. This may be a Monarch problem as I will explain.

      a couple of times a week one or another of the jobs will not run and the log reads:

      "The join data source is either missing or invalid or wrong password." 

      This moring when I opend the file and applied the model it worked perfectly. I reran the job and it worked fine. (?)

      The Monarch part is that with 7.2 sometimes the join with also come up as missing and you have to go find it then it switchs from "does not exist", to "Exist".

        • Random errors in jobs
          joey

          I occasionaly had problems where a model or project could not be found. When I tried to run the process again, it completed with no errors.  I always blamed this on network trafic, although It was somewhat annoying but not frequent enough to warrant any more investigation.

           

          Also, if you're using monitoring I know there's a limit to the number of files you can monitor, somewhere arround 56-60.  I've found that if you manage to exceed that limit, the Data Pump monitoring peice crashes sporadically, but I don't think that would explain your problems. My hunch would still be network problems.

          • Random errors in jobs
            Bill Tilghman

            Thanks... we're running on a 100 MB Ethernet with the servers on 1000 MB cards and have just moved to active directory. This is different from the NT domain setup of years past, but the problem is as ramdon now as then.

            You can never tell when it will hit.

             

            One thing I did find out is if the report has no data the job will fail since it

            has no match to form the join. 

            That's OK.

            • Random errors in jobs
              Bill Tilghman

              This problem seems to be with a specific job. I'm wondering if the .XPRJ file has gone bad?  I was thinking at one point that the JOIN was being used but by the job AND by a number of associated using Monarch.

               

              I'm back to suspecting the XPRJ file since it is always the same job that can't find the join.

              • Random errors in jobs
                Dee Moore

                Hi Bill,

                 

                I would strongly advise considering an upgrade to MDP 8.5.

                 

                This version addresses many of these issues by offering the Option to Verify if the Report does or does not produce any records. You have the option to continue or stop the Process.

                 

                Make sure you are using UNC Paths and are not Mapping.

                 

                The problem could happening because the .xprj is corrupt......

                Could be due to Network interruptions......

                Is the file unusually large? Do you have enough resources on the machine?.....

                Could another person, application, or process be trying to access the file at the same time it is being processes?.....

                 

                 

                Regards,

                Dee Moore

                Datawatch Tech Support