4 Replies Latest reply: May 15, 2014 9:59 AM by Todd H F RSS

    Exporting deliminated

    Todd H F

      When exporting my table to a deliminated text file I'm not getting the delimination marks.  I'ved tried commas, tab, semicolon.  Nothing is placed.  I tried the adding an extra space and it works but not very helpful for what I need.  Any ideas of whats going on?

        • Exporting deliminated
          Grant Perkins

          Todd,

           

          Which Monarch version?

           

          Are you specifying the file extension for your export file?  (.csv for comma separated, .tab for tab separated for example). How are your export options defined? Manual or automated export or both?

           

          Grant

           

          Originally posted by Todd H F:

          When exporting my table to a deliminated text file I'm not getting the delimination marks.  I'ved tried commas, tab, semicolon.  Nothing is placed.  I tried the adding an extra space and it works but not very helpful for what I need.  Any ideas of whats going on? /b[/quote]

          • Exporting deliminated
            Todd H F

            I'm using Monarch 7 Pro.  I'm not sure what you are meaning by the extension. I setup the export options as deliminated text with a semi-colon.  Then I create a export selext deliminated which applies a .txt extension and saves.  As far as I can see it should add the semi-colons between the colums.

            • Exporting deliminated
              Grant Perkins

              Todd,

               

              Sorry, I was not entirely clear.

               

              I don't have my V7 system running just at the moment but there are 2 types of text output to choose from - fixed length and delimited.

               

              Fixed length does not require and does not include the separators. By default any export with a .TXT extension will be a fixed length file, not delimited.

               

              Delimited, when selected, does not add a file extension (e.g. .csv, .tab, etc.) automatically but you can apply your own. This does not affect the format but will possibly cause some confusion to the Windows Associations for other applications. If you give it a .txt extension a fixed length file will be produced.

               

              I have not seen any problems with V7 exports but I must be honest and say I cannot be sure that I have tried an export with semicolons although that is a standard option.

               

               

              I hope this helps. Sorry for the earlier confusion. If V7 not like that let us know and I will check it ASAP.

               

              Grant

               

              Originally posted by Todd H F:

              I'm using Monarch 7 Pro.  I'm not sure what you are meaning by the extension. I setup the export options as deliminated text with a semi-colon.  Then I create a export selext deliminated which applies a .txt extension and saves.  As far as I can see it should add the semi-colons between the colums. /b[/quote]

              • Exporting deliminated
                Todd H F

                I tried adding the extensions you mentioned and it has worked but only if I force my own extenstion.  If you fail to select your own extenstion even after selecting deliminated it will automaticly add .txt and delete the delmination functions.