1 Reply Latest reply: May 15, 2014 9:59 AM by Grant Perkins RSS

    Model Creation with inconsistent number of lines per record

    MorseB _

      I am having trouble creating a model that works correctly.  I have data records that noramlly use two lines to display all the data.  Each new record starts wit mm/dd continuation record line starts with text.  When I have two records and one only has one line of data, information is not put together correctly in the table view.

       

      Thanks.

        • Model Creation with inconsistent number of lines per record
          Grant Perkins

          Hi Beth,

           

          Sounds like you always have line 1 starting with mm/dd but not always line 2 which starts with text. If there is NO LINE 2 - is the line after line 1 BLANK? If it is, this solution has a chance of working.

           

          I am always happier making a proposal if I have seen an example of the report but, in this case it sounds like line 1 should be your ONLY DETAIL LINE.

           

          Line 2 probably needs to be an APPEND but TRAPPED using the same trap area as line 1. I like to make them a little different so I don't confuse myself! So I might make the DETAIL trap something like /dd and the append trap based on mm/ . There may be reasons why you have to do something different of course.

           

          That way you will always get the line 1 fields and only get the line 2 fields where they exist.

           

          If there is NO BLANK LINE where the line 2 does not exist we need to look for an alternative solution, possibly involving the identification of fields in line 2 by using the 'preceeding string' concept. But to go to that level I think we may need to see a sample layout of the report in order to ensure we are on the right track.

           

          I hope this helps a little.

           

          Grant

           

           

          Originally posted by MorseB:

          I am having trouble creating a model that works correctly.  I have data records that noramlly use two lines to display all the data.  Each new record starts wit mm/dd continuation record line starts with text.  When I have two records and one only has one line of data, information is not put together correctly in the table view.

           

          Thanks. /b[/quote]