3 Replies Latest reply: May 15, 2014 9:58 AM by Grant Perkins RSS

    Weird Trap Results

    Steve Kearley

      I am using a Page Header 4 line trap.  Defining the trap works well and most fields pull accurately, except for one specific field.  On the 2nd line of the trap, I have a field that pulls a report header, but for some reason, the last character is being cut off, but not on every record???

       

      -


                  ACCOUNTS RECEIVABLE SUMMARY BY Account control FOR PRIMARY DOCTOR #1 -  BILLIE Z. AUSBERG, M.D.

      -


       

      This is what the second line looks like.  The field, due to varying lengths, pulls leading and trailing blanks.  But this record in particular, will NOT pull the last period.  So once I trim blanks and pull out the name, I get--

      BILLIE Z. AUSBERG, M.D

       

      I have checked the display width and template width, and both are adequate, apparently and are set at 113.  Don't know if its a report issue or what but didn't know if there was some field limitation in Monarch that was causing me to drop that last period.  Again, on other, shorter records, the last period IS picked up. 

       

      Any help is appreciated,

      Steve

        • Weird Trap Results
          Grant Perkins

          Have you tried setting the field wider?

           

          Also maybe check the last character of the field you get using ASC() ? Could be something invisible in there which is causing the problem.

           

          See

           

              [url="http://mails.datawatch.com/cgi-bin/ultimatebb.cgi?ubb=get_topic;f=1;t=000099#000004"]http://mails.datawatch.com/cgi-bin/ultimatebb.cgi?ubb=get_topic;f=1;t=000099#000004[/url]   

          for something slightly similar (perhaps).

           

          If neither of those, then very strange!      :confused:    

           

          Grant

           

              Originally posted by Steve Kearley:

          I am using a Page Header 4 line trap.  Defining the trap works well and most fields pull accurately, except for one specific field.  On the 2nd line of the trap, I have a field that pulls a report header, but for some reason, the last character is being cut off, but not on every record???

           

          -


                      ACCOUNTS RECEIVABLE SUMMARY BY Account control FOR PRIMARY DOCTOR #1 -  BILLIE Z. AUSBERG, M.D.

          -


           

          This is what the second line looks like.  The field, due to varying lengths, pulls leading and trailing blanks.  But this record in particular, will NOT pull the last period.  So once I trim blanks and pull out the name, I get--

          BILLIE Z. AUSBERG, M.D

           

          I have checked the display width and template width, and both are adequate, apparently and are set at 113.  Don't know if its a report issue or what but didn't know if there was some field limitation in Monarch that was causing me to drop that last period.  Again, on other, shorter records, the last period IS picked up. 

           

          Any help is appreciated,

          Steve /b[/quote]

           

          [size="1"][ February 09, 2006, 09:32 AM: Message edited by: Mary Lou Sullivan ][/size]

          • Weird Trap Results
            Steve Kearley

            I did try widening the field, and for some reason ??????, it worked!  I'm glad it worked but wish I understood why it didn't.

             

            I don't think it was a last character recognition issue since shorter data records that ended in a period did indeed pull properly.

             

            Strange, but fixed for now.

             

            Thanks for the help.

            Steve

            • Weird Trap Results
              Grant Perkins

              Glad you have a solution!

               

              However I still suspect something odd in your report - possibly in the original data way back in the source system. It may be showing up (or will show up) in other places later. Something like a TAB or <CRLF> which can remain invisible within a data source file might be the cause.

               

              I would suggest getting someone with access to the source record to re-key that section of the data record from which the name is obtained and then see what happens next time you extract (with the shorter field length).

               

              Of course if the final period is outside the 113 character Monarch field display anyway it may simply mean that the auto field identification, assuming you used that, stopped assessing before it got to that record. It works on a restricted number of rows if my memory is correct. In which case all that has happened is that you have at least one record with a field requirement longer than the assessment found.

               

              Grant

               

                Originally posted by Steve Kearley:

              I did try widening the field, and for some reason ??????, it worked!  I'm glad it worked but wish I understood why it didn't.

               

              I don't think it was a last character recognition issue since shorter data records that ended in a period did indeed pull properly.

               

              Strange, but fixed for now.

               

              Thanks for the help.

              Steve /b[/quote]

               

              [size="1"][ June 18, 2003, 10:36 AM: Message edited by: Grant Perkins ][/size]