3 Replies Latest reply: May 15, 2014 9:57 AM by Grant Perkins RSS

    Export Problem

    Bradl Vogl

      I am opening a comma delimited file, filtering, calculating and want to export using a "|" field delimiter and no text qualifiers.

      I set the  Options/Export and Clipboard/text files.....I unchecked the "put quotes" box and checked character as Other then | (I believe the | character is ASCII code 124, not sure)

      I then export the file as a text delimited and the result is tab delimited with no quotes.

      What am I missing?

       

      From this:

       

      [font="courier"]

      •             HELP       ******************************      99984.00          0.00          0.00               0.0000

      .5MF 600V CAP CAPACITORS .5 MFD CAPACITOR 600V                  99.00          0.00          0.00               1.0000

      0             RODELCO     RODELCO = ETA-USA                      0.00          0.00          0.00               0.0000

      0-16          UTC MFG     UTC MFG                                0.00          0.00          0.00             127.5000[/font][/quote]To This:

      [font="courier"]|HELP|*****************************|99984|0|0|0

      .5MF 600V CAP|CAPACITORS|.5 MFD CAPACITOR 600V|99|0|0|0.1

      0|RODELCO|RODELCO = ETA-USA|0|0|0|0

      0-16|UTC MFG|UTC MFG|0|0|0|127.5

      /font[/quote]Thanks,

      Brad Vogl

       

      [size="1"][ September 30, 2005, 02:39 PM: Message edited by: BradVogl ][/size]

        • Export Problem
          Grant Perkins

          Brad,

           

          Out of interest, what did you set the export file extension to?

           

          Also which version of Monarch are we investigating?

           

           

          Grant

          • Export Problem
            Bradl Vogl

            Grant,

                 Thanks for the hint.

                 It was saving it as .txt when I selected delimited text.

                 I changed it to .csv and it worked.

                 So, slecting fixed length text or delimited text has a default extension of .txt in the program? I'm glad you have this forum available.

                 Thanks for the help.

             

            Regards,

                   

            Brad Vogl

            • Export Problem
              Grant Perkins

              Originally posted by BradVogl:

              Grant,

                   Thanks for the hint.

              /b[/quote]My pleasure!

               

              I will confess that I left it as a hint because it is a while since I used that sort of export and I could not remember the exact details and did not have time to try it out at that moment!

               

              On the other hand I find I remember things more easily in the future if I have at least partly uncovered the solution for myself rather than just following instructions so I tend to assume that others will retain the same benefit from such activity. 

               

              As I recall the .txt export uses the Clipboard Tab options which are probably set to Tab delimited output files unless you have changed them.

               

              The rationale would be that .txt files are very likely to be associated with something like Notepad on all windows systems and to provide some other form of output with a .txt extension could be very confusing. Indeed many people might expect a 'normal' text structure output when using a .txt extension, whatever a 'normal' output is.

               

              It is a bit obscure. I would be tempted to give it some other extension  - .bar perhaps unless that clashes with some other application? - since .csv is so strongly associated with comma separated values. But that just a personal thing.

               

              Have fun.

               

              Grant