1 Reply Latest reply: May 15, 2014 9:57 AM by Data Kruncher RSS

    This operation requires the merged cells to be identically sized

    nener _

      I export using a filter and a summary only from Monarch 9.01 to Excel 2002. I am not using any hidden fields, calculated fields or any of the advanced Excel features. The file has to be sorted after export. When the file in Excel is opened, sort attempts result in "This operation requires the merged cells to be identically sized" error. The whole page must be selected and unmerged. The data is unchanged but sorting is enabled. How can I export this file to Excel without Excel believing there is a merge somewhere?

        • This operation requires the merged cells to be identically sized
          Data Kruncher

          Hi nener,

           

          Any time that you create a summary with subtotals Monarch sets it up with the equivalent of merged cells for the subtotal titles.

           

          I don't believe that we have any simple control over this functionality within Monarch, but I can offer a workaround in Excel.

           

          The simplest solution, in terms of day to day usability, would be to create a button in your toolbars which would undo the cell merges for you.

           

          All you really need is a single line of code in a macro. Then you assign that macro to the toolbar button, so that it runs every time you click the button. The best place to store this code is in a code module in the PERSONAL.XLS workbook.

           

          [font="courier"]ActiveSheet.Cells.MergeCells = False  /font[/quote]Let us know if you need further assistance on how to do this.

           

          Just because every possible option doesn't exist within Monarch doesn't mean that you're truly limited in how you use Excel with Monarch.        

           

          Kruncher