4 Replies Latest reply: May 15, 2014 9:56 AM by chuck _ RSS

    Eliminate Extra CR/LF in Exports?

    chuck _

      Hi everyone.

       

      Any ideas how to eliminate an extra CR/LF at the end of my exports?

       

      I’m getting an extra CR/LF at the end of my exports (text or .mdb exports).  This causes a blank record in my database when I import the text file.  It also causes a blank record in my table when I export directly to a database. 

       

      Any ideas will be appreciated.

       

      Thanks - chuck

        • Eliminate Extra CR/LF in Exports?
          Grant Perkins

          Hi Chuck,

           

          Welcome.

           

          Can you advise which version/release of Monarch you are using and how your Export Options are set?

           

          Can't be sure knowing will help but I'm sure it cannot harm.

           

          Best regards

           

          Grant

           

          Originally posted by chuck:

          Hi everyone.

           

          Any ideas how to eliminate an extra CR/LF at the end of my exports?

           

          I’m getting an extra CR/LF at the end of my exports (text or .mdb exports).  This causes a blank record in my database when I import the text file.  It also causes a blank record in my table when I export directly to a database. 

           

          Any ideas will be appreciated.

           

          Thanks - chuck /b[/quote]

          • Eliminate Extra CR/LF in Exports?
            chuck _

            Hi Grant.

             

            Thanks for welcome and the reply. 

             

            Here are the details:

             

            Monarch v6.01.

            Export & Print: Only thing I have checked is Use Quoted character fields in delimited text files. 

             

            I've experimented with several settings in the Export & Print Options, but so far I'm not having any luck. 

             

            Thanks - chuck

             

             

            Originally posted by Grant Perkins:

            Hi Chuck,

             

            Welcome.

             

            Can you advise which version/release of Monarch you are using and how your Export Options are set?

             

            Can't be sure knowing will help but I'm sure it cannot harm.

             

            Best regards

             

            Grant

             

              /size[quote]quote:[/size]Originally posted by chuck:

            Hi everyone.

             

            Any ideas how to eliminate an extra CR/LF at the end of my exports?

             

            I’m getting an extra CR/LF at the end of my exports (text or .mdb exports).  This causes a blank record in my database when I import the text file.  It also causes a blank record in my table when I export directly to a database. 

             

            Any ideas will be appreciated.

             

            Thanks - chuck /b[/quote][/b][/size][/QUOTE]

            • Eliminate Extra CR/LF in Exports?
              Grant Perkins

              Hi Chuck,

               

              I assume you are importing from a report file?

               

              Have you also tried adjusting the import settings?

               

              If the input is the problem I would expect you to see an extra blank record in the resulting Monarch table.

               

              I seems to recall seeing that effect when the imported report was interpreted as having 2 cr/lf at the end when it was intended to be an end of document marker.

               

              Check for matching cr/lf's and number of lines.

               

              The examine.exe utility should be useful for that if required.

               

              If the source of the extra line is not the original file we will need to think again

               

              Do you get this with all files by the way?

               

              If you create your own small file using notepad do you still get the problem?

               

              I would be happy to try it out on my system if there is no problem about data sensitivity or file size.

               

              Grant

               

               

              Originally posted by chuck:

              Hi Grant.

               

              Thanks for welcome and the reply. 

               

              Here are the details:

               

              Monarch v6.01.

              Export & Print: Only thing I have checked is Use Quoted character fields in delimited text files. 

               

              I've experimented with several settings in the Export & Print Options, but so far I'm not having any luck. 

               

              Thanks - chuck

               

              [/quote]

              • Eliminate Extra CR/LF in Exports?
                chuck _

                Hi Grant.

                 

                Thanks for the ideas.  I'll give them a try.

                 

                Unfortunately, my hard drive crashed, so I'll have to wait until it's re-built before I can try anything.  (I hate it when that happens!)

                 

                Thanks again! - Chip

                 

                 

                Originally posted by Grant Perkins:

                Hi Chuck,

                 

                I assume you are importing from a report file?

                 

                Have you also tried adjusting the import settings?

                 

                If the input is the problem I would expect you to see an extra blank record in the resulting Monarch table.

                 

                I seems to recall seeing that effect when the imported report was interpreted as having 2 cr/lf at the end when it was intended to be an end of document marker.

                 

                Check for matching cr/lf's and number of lines.

                 

                The examine.exe utility should be useful for that if required.

                 

                If the source of the extra line is not the original file we will need to think again

                 

                Do you get this with all files by the way?

                 

                If you create your own small file using notepad do you still get the problem?

                 

                I would be happy to try it out on my system if there is no problem about data sensitivity or file size.

                 

                Grant