3 Replies Latest reply: May 15, 2014 9:56 AM by Grant Perkins RSS

    Microsoft Access field oddity (using v9)

    AlexM _

      I don't know whether it's a bug in v9 or just my ignorance but when picking up an Access database file, certain fields are correctly showing as "Numeric" in the field list view yet the Field Properties "Type" box (when the column is double-clicked) appears as blank.

       

      Any ideas? (I can circulate screen dumps via email if necessary.)

       

      There's been no change to the Access database structure and I don't recall this happening with v8 so it's something of a mystery.

        • Microsoft Access field oddity (using v9)
          Grant Perkins

          Hi Alex,

           

          That sounds a little strange.

           

          I have just checked a few of the mdb files lying around on my system (though not many have very large numeric fields) and all display correctly, mostly set to display width = 10, and none so far have produced the problem you describe.

           

          Off the top of my head I can't think how such a situation might arise. Are you loading the file as it comes or applying a model to it as part of the load?

           

           

          Grant

          • Microsoft Access field oddity (using v9)
            AlexM _

            Hi Grant

             

            I'm running the mdb file via a project so a pre-existing model would be applied.

             

            Perhaps it's worth starting from scratch with v9 (were you using this version or v8 for your test?) to see what the result looks like but I've pitched this to Gareth with a sample of the database for further investigation.

             

            Very odd indeed!

             

            Alex

             

            -


             

            Hi Alex,

             

            That sounds a little strange.

             

            I have just checked a few of the mdb files lying around on my system (though not many have very large numeric fields) and all display correctly, mostly set to display width = 10, and none so far have produced the problem you describe.

             

            Off the top of my head I can't think how such a situation might arise. Are you loading the file as it comes or applying a model to it as part of the load?

             

             

            Grant

             

            -


            V5 : Win98 SE

            V6 ?

            V7, V8: Win XP Home SP1/2

            V8 : Win XP Pro SP2

            • Microsoft Access field oddity (using v9)
              Grant Perkins

              Hi Alex,

               

              I was using 9.

               

              One can see odd things with seemingly empty fields where something has come up left justified in a display width less than the data width and the actual data being insufficient to appear, but that is rare and more likely in character fields of course.

               

              But an empty Type from one window only seems odd.

               

               

              Grant