2 Replies Latest reply: May 15, 2014 9:56 AM by Lynette _ RSS

    Trapped

    Lynette _

      Am using Monarch pro v7.1.

       

      Have set-up templates to extract costs, which have various components against a particular invoice. Being more detailed I have set-up the costs as the  "Detail" template, while the invoice no  the "append" template.

       

      All works well as long as there is a cost component (single or multiple).. However when a particular invoice has no cost (not even "0.00") the invoice is not being reflected in the table. Any ideas on how to get my table reflect all invoices i.e. those with "nil" costs and those with detailed costs.

       

      e.g

      A0001                  

      A0002                   AAA USD 100.00

                              BBB USD  50.00

       

      The table shd appear as follows:

      A0001

        • Trapped
          Grant Perkins

          Lynette,

           

          You could consider making the Invoice Number the detail and the 'append' the costs but I sus[ect that woould simply add more complexity somewhere else.

           

          A basic solution would be either of the following.

           

          Use your existing model to extract invoices with value. Use a second model to extract the invoice numbers with no values (Invoice number = detail but ONLY if values are zero/blank/whatever.)

           

          Make the format of the output files the same. Concatenate them using the method for concatenation you prefer. I would think that using the Project Exports and sending the 2 results to the same file or table could probably work.

           

          I hope this helps.

           

          Grant

           

           

          Originally posted by Lynette:

          Am using Monarch pro v7.1.

           

          Have set-up templates to extract costs, which have various components against a particular invoice. Being more detailed I have set-up the costs as the  "Detail" template, while the invoice no  the "append" template.

           

          All works well as long as there is a cost component (single or multiple).. However when a particular invoice has no cost (not even "0.00") the invoice is not being reflected in the table. Any ideas on how to get my table reflect all invoices i.e. those with "nil" costs and those with detailed costs.

           

          e.g

          A0001                  

          A0002                   AAA USD 100.00

                                  BBB USD  50.00

           

          The table shd appear as follows:

          A0001 /b[/quote]

          • Trapped
            Lynette _

            Thanks did 2 seperate models as ran thro a batch file.