3 Replies Latest reply: May 15, 2014 9:56 AM by Data Kruncher RSS

    Can I run two versions on the Same PC

    gpotenza _

      I just realized that Version 8 created xprj files instead of the PRJ files that my other users with a previous version are used to and still need.  In order to maintain the project files is it possible to run two versions on the same PC?

        • Can I run two versions on the Same PC
          Data Kruncher

          Yes, you can run multiple versions on the same PC - simultaneously no less.

           

          I run v8 Pro and v5 Standard to support older installations as you mention.

           

          There are other users here who likely have even more versions installed.

           

          HTH,

          Kruncher

          • Can I run two versions on the Same PC
            Grant Perkins

            As Kruncher observes running different version side by side for support purposes is possible.

             

            The only thing to be aware of is that the registry entries, which define the system 'defaults' (for file and folder locations for example) may end up shared between both versions depending on the choices made during the installations. I always think it it useful to create a new installation in its own folder. If nothing else it reduces the disruption should anything go wrong. But you then need to remember that this is different to 'standard' in some ways and so be able to take that into account if odd things happen when following tutorial documentation! (for example).

             

            It's not a big concern but may cause some degree of confusion if you are not aware of it.

             

             

            Grant

            • Can I run two versions on the Same PC
              Data Kruncher

              One other point regarding having multiple versions installed is worth mentioning to you.

               

              When running Monarch via automation (VBA programming and the like), my experience is that the Monarch version which will run when your program creates the Monarch object will be the last one you ran manually. You cannot specify which version to run when creating the Monarch object - or at least I don't know how.    

               

              Just something to watch out for.

               

              Kruncher

               

              I suppose you could "run" the intended version via a shell statement, then use GetObject instead of CreateObject, but I haven't tried that.