4 Replies Latest reply: May 15, 2014 9:55 AM by Hin _ RSS

    PDF Import Problem

    Hin _

      I have Monarch V8 Pro and have 8.01 update installed.   Monarch often returned a "timeout" error when I tried to open a PDF file.  It did not even get to the Import Option stage.  The files were not big at all. They were less than a hundred pages.  Some were as small as around 300k in size.

       

      For the few PDF reports Monarch was able to imported.  The data displayed on the Report window was mis-aligned.  The data columns were perfectly aligned when I viewed the report with Acrobat Reader or printed it on paper.  None of the solutions suggested in this forum solved the problems.  The pdf reports are not scanned images for sure.

       

      Any suggestions/help would be greatly appreciated.

        • PDF Import Problem
          Grant Perkins

          Hi,

           

          There are a lot of different PDF writing programs around and some can produce code that is not always easy to read with pdf reading applications. It sounds like the source for some of your reports may suffer from that.

           

          If you have access to a copu of Acrobat (not the reader version but the full version, preferably the Pro level) you could try opening the file for edit and re-saving it. There are a number of posts in the forum suggesting that doing so often provided a solution for a problem file.

           

          It might also be interesting to see what sort of output you get if you use the Export to Text (or similar name) function in the reader application. If this is badly formed it might also suggest some internal problems with the pdf instructions.

           

          Some time ago (pre 8.01) there was a thread asking for problem file examples (files to be provided) for investigation. It is possible that your problem files might also be of interest since this sort of development is always likely to be a candidate for constant adjustments.

           

          HTH.

           

           

          Grant

          • PDF Import Problem
            Hin _

            Thanks for the advice.  I tried that already--opening with a full version of Acrobat and saved the report again.  It did not help at all.  I would like to send the file for them to look at. Unfortunately, the reports in questions were payroll reports from ADP.

             

            Thanks in any case.

            • PDF Import Problem
              Dee Moore

              Hi HIN,

               

              Addressing the "Timeout" first:

               

              Monarch does "Timeout" at 10 seconds.

               

              I have come across this a few times. When Monarch opens a file it writes to your Temp Directory. If there isn't enough Free Space, a "Timeout" error will be thrown. So it may be time to do a little housekeeping.

               

              I have also seen this error occur when the PDF file contains errors due to the way it was produced. Monarch tries to make sense of it and open it, but due to eratic formatting, it can't.

               

              Since you state that when a file does open for you the structure of the data is not aligned, if it is grossly misaligned, the later could be true.

               

              I would be more than happy to send you a Non-Disclosure Form, if it would be helpful in getting the file to me. We work with sensitive material often and I have no problem destroying files after working to resolve an issue.

               

              Feel free to contact me:

               

              dee_moore@datawatch.com[/email]

               

              Regards,

              Dee Moore

              Datawatch Tech Support

              • PDF Import Problem
                Hin _

                How can I get the pdf file to you, Dee?