1 Reply Latest reply: May 15, 2014 9:55 AM by Grant Perkins RSS

    Trap character NOT shown on "R" Trap Line

    maxtsang _

      Hi

       

      I have a problem that the Trap Character (Alpha,

      Numberic, Blank, Non-Blan, Numeric OR Trap)DOESN'T

      show on the "R" trap window when I am designing the Template definition. ( In other words, NO TRAP is set successfully )

       

      I guess it is caused by using CHINSE VERSION of

      win2000 because I have done the same job in ENGLISH VERSION of win2000 and it is works.

       

      Do you have a solution for it. Besides my guess, what other thing will cause this problem, how can solve it.

       

      Looking forward any Super user's reply

        • Trap character NOT shown on "R" Trap Line
          Grant Perkins

          Hi max,

           

          You may want official word from the Datawatch team on this one but my guess is that it will be to do with the default font for the system.

           

          The trap characters can be reset to alternate characters using some windows registry settings EXCEPT for the "NUMERIC OR" if my memory is correct.

           

          My suggestion is to check the Monarch Help which covers the entries in some detail. Use the word 'settings' to get to the relevent section and scroll down to 'hidden settings' and then on until you get to the section that covers the trap characters.

           

          MapAlphaTrapTo

          MapNumericTrapTo

          MapBlankTrapTo

          MapNonblankTrapTo

           

          I am not sure what you can do about the 'pipe' character for the "numeric OR". Can you make that character available alongside your existing font?

           

          I hope this helps a little.

           

          If it offers no benefits at all I think you may need to talk to Monarch Tech Support.

           

          Good luck.

           

          Grant

           

            Originally posted by maxtsang:

          Hi

           

          I have a problem that the Trap Character (Alpha,

          Numberic, Blank, Non-Blan, Numeric OR Trap)DOESN'T

          show on the "R" trap window when I am designing the Template definition. ( In other words, NO TRAP is set successfully )

           

          I guess it is caused by using CHINSE VERSION of

          win2000 because I have done the same job in ENGLISH VERSION of win2000 and it is works.

           

          Do you have a solution for it. Besides my guess, what other thing will cause this problem, how can solve it.

           

          Looking forward any Super user's reply /b[/quote]

           

          [size="1"][ November 25, 2003, 01:03 PM: Message edited by: Grant Perkins ][/size]