1 Reply Latest reply: May 15, 2014 9:54 AM by Grant Perkins RSS

    Using batch file to export to access from the table

    Bruce _

      Has anyone else tried to export using a batch file into an access table?

       

      I used a px switch of a project file that works fine if I open up Monarch manually, but cannot get it to work in batch mode.

       

      All the other exports from the summary line work fine. Also instead of the px switch I used the full set of parameters /rpt /mod /exp /expfileopt etc and this fully qualified (but very long) statement worked fine.

       

      EG this did NOT work:

      [font="courier"]  "C:Program FilesMonarchProgramMonarch.exe" /prj:"C:Program FilesMonarchProjectsForecast.xprj" /px:"Forecast" /font[/quote](I also tried px:Forecast)

       

       

      But this statement works fine:

      "C:Program FilesMonarchProgramMonarch.exe" /rpt:"C:Program FilesMonarchReportsForecastDemands.txt" /mod:"C:Program FilesMonarchModelsForecast.xmod" /px:Forecast /exp:"c:Program FilesMonarchExportForecast Only.mdb" /expfileopt:add /exptable:Forecast /exptableopt:overwrite

       

      I'm using Monarch 9.01, Access 2002 and Win XP Sp2

       

      Thanks

      Bruce

        • Using batch file to export to access from the table
          Grant Perkins

          Hi Bruce,

           

          Did you also try your shorter Project related command with the '/expfileopt:add /exptable:Forecast /exptableopt:overwrite' included?

           

          As I understand it doing so should not be necessary but Access can be funny sometimes it seems.

           

          Are the Project Export parameters the same as the ones set for the batch command? Is there any possibility that for some reason in the automatic process the database you are exporting already thinks it has that table and it is protected?

           

          Just thinking aloud.

           

           

          Grant