2 Replies Latest reply: May 15, 2014 9:53 AM by Oli _ RSS

    Format Problems

    Oli _

      Hello I try to import the figures of the colums, but I can only can define it as a charcter. But thats not enough, because I have to make further calculations. So the numeric format is obliged.

      I think the problem are the thousand seperators. How can I help Monarch to handle it ?

       

      [font="courier"]| |2800|****|023123 100010     XXXX XX XXXX xxxice             |    2.149.118,00  |    4.030.885,00  |   1.881.767,00-|  46,7-|    |

      2800

      023124 100010     XXXX XX hand Oxxice Fxx Exx

      156.171,58

      22.620,69

      133.550,89

      590,4

      | |2800|****|023125 100010     XXXX XX hxxx xxxx 1             |      813.821,00  |      863.574,00  |      49.753,00-|   5,8-|    |  /font[/quote]Oli

        • Format Problems
          Mike Urbonas

          I assume you are opening your file as a database; Monarch Pro can read this delimited file as a database (as opposed to a text file requiring a model to be created), specifing the pipe character | as the delimiting character.

           

          As for numeric fields being recognized only as character fields -- be sure you have defined your decimal character as a comma, not a period (in Monarch, go to: Options -> Input... and see "Numeric Translation - Decimal Character.")

          • Format Problems
            Oli _

            Thanks!!!! The changing within the Input... from Settings give me the correct values. ->set to comma for decimal characters.

             

            Oli