4 Replies Latest reply: May 15, 2014 9:53 AM by Gareth Horton RSS

    Smart Copy feature

    Lenny _

      There are times when I just ned to open a report and copy a small section to Excel.  Use to work great as Monarch automatically separated the data into individual spreadsheet cells.  I just upgraded to Excel 2007 and found that when I paste, all columns of data appear in one cell and is not parsed out.  The only way I can do it is to paste special and use fixed format.  The only problem is it requires more keystrokes and even then the text columns are broken out incorrectly.  I'm trying to identify if this is a result of upgrading to Excel 2007 (didn't have the problem in Excel 2003) and if v9 will rectify it.  It didn't happen to me before.  Thanks

        • Smart Copy feature
          Bruce _

          Hi Lenny & welcome to Monarch

           

          You don't mention what version of Monarch you are using. However if you can go into the export & clipboard settings from the main menu, clipboard setting you can change some setting that might help you. If you have version 8 (or better) try changing the setting to text format fixed (version 7).

           

          Good luck

          • Smart Copy feature
            Nick Osdale-Popa

            According to Lenny's profile, the version being used is 5.02.

            • Smart Copy feature
              RalphB _

              Lenny,

               

              We haven't upgraded to Office 2007 at work but I do have a copy at home along with Monarch 9 Pro at home for testing purposes.

               

              I tried to copy/paste like you and ended up with the same results with Excel 2007.  I had no problem copying/pasting into Excel 200 at home.  So, I assume it has something to do with Excel 2007 unless someone else has more experience.

               

              I would recommend you upgrade to Monarch 9 Pro.  It has a multitude of enhancements over your version that would, in my opinion, be worthwhile the expense.

              • Smart Copy feature
                Gareth Horton

                Hi,

                 

                In V8 and above there is an option to copy to the clipboard in Tab-delimited format.

                 

                This works in Excel 2007, but the old method (fixed-length text) does not appear to work in Excel 2007.

                 

                It looks like it is due to the Text Import Wizard now getting involved in Paste operations.

                 

                (not relevant to your issue, but mentions the TIW now dealing with Paste)

                 

                [url="http://support.microsoft.com/kb/280604"]http://support.microsoft.com/kb/280604[/url]

                 

                 

                Gareth

                 

                 

                Originally posted by Lenny:

                There are times when I just ned to open a report and copy a small section to Excel.  Use to work great as Monarch automatically separated the data into individual spreadsheet cells.  I just upgraded to Excel 2007 and found that when I paste, all columns of data appear in one cell and is not parsed out.  The only way I can do it is to paste special and use fixed format.  The only problem is it requires more keystrokes and even then the text columns are broken out incorrectly.  I'm trying to identify if this is a result of upgrading to Excel 2007 (didn't have the problem in Excel 2003) and if v9 will rectify it.  It didn't happen to me before.  Thanks /b[/quote]