2 Replies Latest reply: May 15, 2014 9:53 AM by Jing _ RSS
      • Unable to create some traps in Monarch 5.02
        Grant Perkins

        Hello Jing and welcome!

         

        I suspect that you problem is that the Monarch SETTINGS in the registry are unable to find a character to display in the Language setting for your PC.

         

        I hope that your Monarch system has the Help file installed and that the help contains some information about SETTINGS, particularly the HIDDEN registry settings for

         

        MapAlphaTrapTo

        MapNumericTrapTo

        MapBlankTrapTo

        MapNonblankTrapTo

         

        These allow you to over ride the default settings and identify which characters you wish to use.

         

        Now at this point I have to say that I have no experience of using the Chinese character sets and I am not sure if the 5.02 system you have has previously worked and displayed correctly with a different operating system or language setting. So I may be offering information which will not help you. However at the moment checking these settings appears to be your best and quickest option and at least allows you to see what is there and eliminate the possibility from the possible problems list if it does not lead to a fix.

         

        I hope this helps.

         

        Grant

        • Unable to create some traps in Monarch 5.02
          Jing _

          Hi Grant!

           

          Thanks for the information.

           

          I have tried to modify the registry values to point to other characters. But it seems that the traps set are still not working well. I am not sure whether this is related to single-byte or double-byte problem.

           

          Anyway, I managed to grab uninstall the software from the Chinese Windows and re-install it on another English Windows 2000 machine. Everything works fine now.

           

          Thanks a lot!