8 Replies Latest reply: May 15, 2014 9:53 AM by Oli _ RSS

    Export tab-delimited

    OJGraf _

      Hello,

      I've got the problem, that when I export my Project to the txt-file, that the format isn't tab-delimited.txt-file.

      Who can I get Monarch export to this file-format.

      If I change the options in the options -> Export

      then the exported file isn't changed. There is no reaction of changing. I tried to use tab but I get only blanks as sepereators. What is wrong ?

        • Export tab-delimited
          Grant Perkins

          The text file delimiter character is set in from

           

          Options > Export and Clipboard Options >

           

          Open the 'Text Files' section.

           

          The specification for exporting as delimited text files, including the separator character to use, is defined in trhe middle section of that screen.

           

          If you already have TAB set there we may need to investigate further. Be sure to save the model and the project if you are using Project Exports.

           

          Let us know if this does not help with your problem.

           

          Grant

          • Export tab-delimited
            OJGraf _

            Thanks Grant,

            I already tried this procedure. But if I change anything in this screen for example "use komma or semikolan" for tab delimited-txt seperator it has no effect for the export. The results is always

            the same: The colums are sepereated with many blanks. But I urgently need tab-delimited txt-file format.

             

            greetings

            Oli

            • Export tab-delimited
              Grant Perkins

              Oli,

               

              That does sound odd.

               

              If you are exporting the file manually you are offered a suggested output path and file name which will probably be filename.txt  .

               

              Presumably you wouold then re-name the file and take the opportunity to set the type of file to be exported.

               

              Your description of the problem suggests that you are actually getting a fixed width output file (Looks like it is columns and there will be at least one space between columns.) This wouold be the default, I believe, for the system and the .txt extension.

               

              Setting file type to delimited (*) should allow you to produce a delimited output with the delimit character specified in your options table.

               

              If this is what you are doing but you still do not get the correct result then it seems you have a problem somewhere that needs to be analysed.

               

              You may find it useful to have a look at the 'Settings' section of the Help system. There you will see information about where the various user defined settings are saved. Typically default settings are in the system registry and model specific settings are in the model file.

               

              I do not have a problem with the export type you want - except remembering to change from my default settings! However I think you will be using a different release of software so there is a small possibility that there is a difference in how this function works. I will try to look that up.

               

               

              Grant

              • Export tab-delimited
                OJGraf _

                Hello Grant,

                I work with release V7.01 Monarch Pro (German Version).

                The strange thing is, that if I make changes in the Export Options for text-files, there is no difference in the result. The file is always saved as fixed txt-file. I tried serveral Options but the export shows always the same result.

                 

                Oli

                • Export tab-delimited
                  Bruce _

                  Oli

                   

                  Try changing the name of the file to .tsv for tab seperated values, .csv for comma seperated values.

                   

                  Monarch seemed to have a problem exporting to files that did not match the file types, even though the file export options are set correctly.

                   

                  Let us know if this helps.

                  • Export tab-delimited
                    bubba _

                    When you export, don't assign an extention to the file name. Just change the extention to .txt afterward and see if it exports as expected.

                    • Export tab-delimited
                      Grant Perkins

                      Oli,

                       

                      Can we just check what you are doing here - V8 and V7 are the same as far as I know.

                       

                      You want to export a table or summary ar a tab delimited text file and you have the options set up correctly (For the de-limited options, if you have at least one alpha field, set the options to enclose text in "").

                       

                      ===========

                       

                      Edit:

                       

                      According to some notes I have found there were some discrepancies with the way the selection box for file types worked in V7 before the 7.01 release. I think the following applies (I don't have a 7.01 installation I can use to check) and I believe that specifying a recognised extension type should work. However there may be some other problems that I have no documentation about.

                       

                      End of Edit.

                       

                      =============

                       

                      If you export to a folder and specify a .txt file (Fixed Length text fields) from the drop down list of available file types you should get a fixed field size output and a formatted report.

                       

                      With your default Option for Delimited file export set to TAB,  export the same data but select the Delimited(*) file type option and specify a .tab extension.

                       

                      You should get a file showing a number of columns but MAYBE some of the data is shifted across the columns. View the file as a REPORT in Monarch and scroll to the right to see if the final field position varies from one record to another. Although the data may look similar to the fixed width output some lines may be different - how different could depend on the sort of data in the file.

                       

                       

                      Or open the file in Wordpad or Word and set it to display formatting characters.

                       

                      Do the same thing but save the file with a .csv extension. It should still look like the .tab file if you have not changed the options for the separator.

                       

                       

                      Repeat again and this time save the file with a new name and as a DELIMITED type BUT use the the .txt extension.

                       

                      The export will default to the fixed width field format related to .txt files. If my memory is correct any "text file" file type export without a specified file extention will default to a .txt extension to the file and therefore be assumed to be fixed width. (I think this is because the .txt extension is commonly used across systems to denote a 'flat' text file and within MSwindows there are specific associations. Therefore it is safer to use a default file output no matter what the user specifies.)

                       

                      Using version 8 the description above is true. (Also if you use Delimited(*) and specify, for example, 'file.oli' as your output you should get a tab delimited file with extension .oli. Assuming, of course, that your delimited text file output is set to TAB delimiter!)

                       

                      The only problem I have with TAB as a delimiter is that it can be very difficult sometimes to tell the difference between tabs and spaces.

                       

                      On the other hand if you try to import the file as a database specifying that it is tab delimited it should be fairly clear whether it is or not ...

                       

                      I hope this helps.

                       

                      If you want to send me some sample output files and the information about what format they should be in, I will be pleased to have a look at them. send me a mail (if you have my address) or a Private Message to confirm your email address has not changed.

                       

                      Grant

                      • Export tab-delimited
                        Oli _

                        Hello Grant,

                        thanks again all for your great help!!

                        I used the .tab extension to export and create a delimited *.txt file. Althogh my file has now the extension: *.tab I don't need to rename the extension to *.txt , because my further upload program of SAP recognizes the content as a tab delimited txt-file(...lucky). I created a batch script file and my process works automated now, without any problems. -)))

                         

                        But, one question. I can't really remember who told me, that Monarch V7.01 has problems with the Jet engine of Windows. Is my problem a result of this and it's so, is there any patch planed to correct this in the near future.

                        Why doesn't a support like multilanguage-patch program exists? As far as I'm informed there is no existing german patch V7.02.

                         

                        Oli