5 Replies Latest reply: May 15, 2014 9:52 AM by NAngel _ RSS

    Table Window

    NAngel _

      Hi all,

       

      I'm new to Monarch and using V7 of Monarch Pro.

      Now I need some help.

      I have trapped a detail line that shows up fine in the table view exactly as selected in the report. the problem is that when I trap an append line that shows correctly in the report view... it will not show the field values in the table view. some fields stay completely empty and some have a line like this: -

      strangely this only applies to the very first line, all the others are fine.

       

        :confused: 

       

      thanks for any ideas on how to solve this, I'm on a deadline and can't figure it out  

        • Table Window
          NAngel _

          Hi all,

           

          I'm new to Monarch and using V7 of Monarch Pro.

          Now I need some help.

          I have trapped a detail line that shows up fine in the table view exactly as selected in the report. the problem is that when I trap an append line that shows correctly in the report view... it will not show the field values in the table view. some fields stay completely empty and some have a line like this: -

          strangely this only applies to the very first line, all the others are fine.

           

            :confused: 

           

          thanks for any ideas on how to solve this, I'm on a deadline and can't figure it out  

          • Table Window
            Grant Perkins

            Hi and welcome to the forum.

             

            Without being able to see an example of the report you are dealing with I will guess that your append may not be quite as required.

             

            Does it get trapped BEFORE the first DETAIL trap?

             

            Empty fields sort of suggest that although the fields exist in the table there is nothing to put in them for those lines. the "-" may be the representation of a NULL value in a numeric field. Have a look at MENU > OPTIONS > VIEW and check the information related to  the display of NULL values at the top of that window.

             

            I could be wrong but it's a good place to start.

             

            If you are stuck can you post a sample of the first few lines of the report (with disguised data if required) and indicate which lines you see as detail and which as part of the append.

             

            Also maybe what your final extraction needs to look like.

             

            Best regards,

             

            Grant

             

            PS - To post a report sample without trashing the formatting use the Instant BB "CODE" button below the message entry screen amd simpl[y paste the lines fo the report between the two tags.

             

            [size="1"][ December 06, 2006, 04:20 AM: Message edited by: Grant Perkins ][/size]

            • Table Window
              Grant Perkins

              Hi and welcome to the forum.

               

              Without being able to see an example of the report you are dealing with I will guess that your append may not be quite as required.

               

              Does it get trapped BEFORE the first DETAIL trap?

               

              Empty fields sort of suggest that although the fields exist in the table there is nothing to put in them for those lines. the "-" may be the representation of a NULL value in a numeric field. Have a look at MENU > OPTIONS > VIEW and check the information related to  the display of NULL values at the top of that window.

               

              I could be wrong but it's a good place to start.

               

              If you are stuck can you post a sample of the first few lines of the report (with disguised data if required) and indicate which lines you see as detail and which as part of the append.

               

              Also maybe what your final extraction needs to look like.

               

              Best regards,

               

              Grant

               

              PS - To post a report sample without trashing the formatting use the Instant BB "CODE" button below the message entry screen amd simpl[y paste the lines fo the report between the two tags.

               

              [size="1"][ December 06, 2006, 04:20 AM: Message edited by: Grant Perkins ][/size]

              • Table Window
                NAngel _

                thanks for the ideas!

                I redid the whole model by using the last line as the detail template and append everything that was on top and it worked great, well at least no more empty or - fields!

                 

                I'm sure I'm going to encounter more problems in the future and will post them up.

                 

                thanks again   smile.gif[/img]

                • Table Window
                  NAngel _

                  thanks for the ideas!

                  I redid the whole model by using the last line as the detail template and append everything that was on top and it worked great, well at least no more empty or - fields!

                   

                  I'm sure I'm going to encounter more problems in the future and will post them up.

                   

                  thanks again   smile.gif[/img]