5 Replies Latest reply: May 15, 2014 9:52 AM by Nick Osdale-Popa RSS

    Shaded Cells when exporting to Excel

    TOMerwick _

      Is there a way to control or disable the shading of the column cells when exporting to Excel.  I'd rather not have the shading at all.  Any other controls related to this?  I.E. centering the column headers?

        • Shaded Cells when exporting to Excel
          TOMerwick _

          Is there a way to control or disable the shading of the column cells when exporting to Excel.  I'd rather not have the shading at all.  Any other controls related to this?  I.E. centering the column headers?

          • Shaded Cells when exporting to Excel
            Grant Perkins

            Hello Tom,

             

            Using V7 a normal Excel Export of a table (no special formatting in Monarch)produces a shaded top row for the Column names in Excel 2000 IF I have the Monarch

             

            Options>Export and Clipboard Options>Apply formatting to XLS files

             

            box ticked.

             

            Un-tick it and the export does not have the shading on the forst row - but it loses some of the other appearance attributes as well, like text formatting in the cells.

             

            What happens my vary according to the versions of Monarch and Excel and which Excel version you are exporting as (irrespective of which version is available).

             

            No doubt someone on the forum will be using the combination you are if you tell us the spec.

             

            Best regards,

             

            Grant

             

             

            Originally posted by TOMerwick:

            Is there a way to control or disable the shading of the column cells when exporting to Excel.  I'd rather not have the shading at all.  Any other controls related to this?  I.E. centering the column headers? /b[/quote]

            • Shaded Cells when exporting to Excel
              Grant Perkins

              Hello Tom,

               

              Using V7 a normal Excel Export of a table (no special formatting in Monarch)produces a shaded top row for the Column names in Excel 2000 IF I have the Monarch

               

              Options>Export and Clipboard Options>Apply formatting to XLS files

               

              box ticked.

               

              Un-tick it and the export does not have the shading on the forst row - but it loses some of the other appearance attributes as well, like text formatting in the cells.

               

              What happens my vary according to the versions of Monarch and Excel and which Excel version you are exporting as (irrespective of which version is available).

               

              No doubt someone on the forum will be using the combination you are if you tell us the spec.

               

              Best regards,

               

              Grant

               

               

              Originally posted by TOMerwick:

              Is there a way to control or disable the shading of the column cells when exporting to Excel.  I'd rather not have the shading at all.  Any other controls related to this?  I.E. centering the column headers? /b[/quote]

              • Shaded Cells when exporting to Excel
                Nick Osdale-Popa

                Monarch V7.01, Win2K, Excel 97 produces the same results as Grant.

                 

                Be aware, though, that the Apply Formatting has no effect on automation. All my VBA automated exports have the shading applied regardless if that option is on or not. Luckily, since I'm already automating it, it's no big deal to unshade that line.

                 

                The only other problem I found in the automation process was when I named a field with a "#". When it exported, Monarch translated it to a ".". I have a routine that looks for column names and that routine halted when it couldn't find the word "Emp#" from an export.    :rolleyes:

                 

                [size="1"][ April 21, 2004, 04:25 PM: Message edited by: Nick Osdale-Popa ][/size]

                • Shaded Cells when exporting to Excel
                  Nick Osdale-Popa

                  Monarch V7.01, Win2K, Excel 97 produces the same results as Grant.

                   

                  Be aware, though, that the Apply Formatting has no effect on automation. All my VBA automated exports have the shading applied regardless if that option is on or not. Luckily, since I'm already automating it, it's no big deal to unshade that line.

                   

                  The only other problem I found in the automation process was when I named a field with a "#". When it exported, Monarch translated it to a ".". I have a routine that looks for column names and that routine halted when it couldn't find the word "Emp#" from an export.    :rolleyes:

                   

                  [size="1"][ April 21, 2004, 04:25 PM: Message edited by: Nick Osdale-Popa ][/size]