1 Reply Latest reply: May 15, 2014 9:51 AM by Data Kruncher RSS

    Append template problem

    InsDataAnalyst _

      I have a problem with how Monarch is appending some data and don't know how to resolve it. I have a fairly details model set up for a report. The report has several levels.  I have detail for patient name, id, claim #, procedure, costs... There could be 3 patients, then a provider id and name, then 1 patient and a different prov id and name, etc. With a header and footer identifying the Group paid that the provider work for.  I have it all captured properly except the Prod ID and Name under the list of patients.  It capture it - but the first 3 lines are blank, then the name that should be on that line is on the next 3 lines - so it's falling below the line it needs to be on.

       

      Any help would be appreciated.

       

      thanks

        • Append template problem
          Data Kruncher

          Hello and welcome!

           

          From your nice description, it sounds to me like you've defined the template for the Prod ID and Name as an "Append" template. I'd simply recommend that you change that setting to a "Footer" template.

           

          Footer templates want to extract data which appears after the fields defined in the Detail template.

           

          I hope that I haven't misunderstood the layout of the report, and how you've modeled so far.

           

          If this does not resolve your challenge, would you mind posting a sample (with private data replaced with x's and 9's) using the Code button? A picture is worth a thousand words and all that...    

           

          HTH,

          Kruncher