1 Reply Latest reply: May 15, 2014 9:51 AM by Steve Caiels RSS

    Unable to create temporary work file - is it MDAC

    Dan _

      On this new install of Monarch Pro V7 (also tried V7.01) I cannot create the work file after a model is developed.  I have also tried opening the sample reports and get this error as soon as I open the correpsonding sample template.  I followed all of the recommendations in the KB article relating to this error and nothing seemed to work.

       

      My concern is that I have Microsoft MDAC 2.8 RTM installed on my XP machine.  Apparently Monarch uses the Microsoft Jet driver, which Microsoft says was deprecated "Starting with version 2.6, MDAC no longer contains Jet components".  Could this be the problem somehow?

       

      I do have dao360.dll stored and registered at C:Program FilesCommon FilesMicrosoft SharedDAO.

       

      The link in Monarch's KB article to install Jet is no longer active, but I did follow a Microsoft link to install Jet 4.0 SP8 and that didn't seem to help either.

       

      Any remaining suggestions?

        • Unable to create temporary work file - is it MDAC
          Steve Caiels

          Hi Dan,

           

          I’ve found that the check Microsoft perform will often report that Jet is fine and no updates are needed when, in fact, they are in a poor state.

           

          Renaming msjet40.dll to something else and trying the update site again will force a new install and may well fix the problems with the workpath.

           

          Regards

          Steve